ForumsSoftware ← aalto and os x yosemite 10.10

haven't done the update yet.
but curious if os x users have. and if so, any compatibility issues to report thus far ?

Yosemite: I haven't tried it here because I have software to write. Someone on another thread was saying that closing windows on the VST versions wasn't working? Hopefully others can chime in with their experiences.

As AU it's working well

Both Kaivo & Aalto load ok and seem to work fine. However, there seems to be a big spike in CPU usage with each in Ableton Live. I'll keep testing and see what else I can find.

Hi all,

32bit VST version of Aalto 1.5 does have the drawing problem in osx 10.10 (using it in Ableton Live 9.1.5 32bit).
It loads fine, works fine but it is impossible to close the GUI window, it leaves a blank white screen that sticks and won't dissapear unless you hit Alt+Tab to switch to another app or finder...
This is annoying!

According to other forums/Ableton statement, this problem is caused by the use of an outdated JUCE Framework...

Dev's will have to update the JUCE library of their plugins to make it work fine in 10.10.
Togu Audio Line already done it and he's plugs works fine now...


For Kaivo, same proloblem as decribed above for me. It works but I get that blank window everytime I close the VST.

Running on a MacBook pro retina with Yosemite and Ableton live 9.1.5


Fixed for the new build, will release ASAP. Thanks for the info.

Great news,
Are you planning to release a "maintenance" update or should we wait for the 1.6 version?

Are there any news for the Yosemite support?

It's fixed and will be out within a couple of weeks.

Perfect, thank you very much!

Any word on this update? Enjoying the demo on my new Macbook Pro Retina, with Ableton 9. But the big CPU spikes, and inability to load presets within the VST window have me hesitating...

I was hoping to get this out yesterday but found one more Windows issue... working on the deploy process now.

Hey, it's out!

Hey Randy. Unfortunately Aalto 1.6 still has the drawing problem for me in Ableton Live 9.1.7 on OS X Yosemite 10.10.2, using the VST version.

That was quick.

Sorry, you are going to have to remind me what drawing problem you are talking about though. I'm going to be doing updates a lot more frequently this year, so hopefully I can get you a fix soon.

never mind, I guess you mean the one above. I have Live 9.1.7 and it's working fine, so I'll have to try Yosemite now.

So the information on JUCE is not right, because I am using the latest version.

According to it is only bound to happen with 32-bit VSTs. And on this page all the way at the bottom someone said the (probably not the best) solution to be

"I found a solution that avoids the remaining black windows, but I am not sure if it will cause any other problems:

I removed the line:

removeWindowHidingHooks (comp);

in file in function detachComponentFromWindowRef()

On Yosemite the window now closes correctly and on Mavericks it still works as before."

Hope that might be of any help.

[EDIT] I just installed Live 64-bit which doesn't have the problem. I was still using the 32-bit version since I thought some of my plugins didn't have 64-bit versions. Apparently I was wrong and I'm quite happy I can go on using the 64-bt version from now on.

Thanks for the additional info, I appreciate it.

No problem. Love Aalto and Kaivo, so I'm happy to lend a hand if possible.

So, I have Yosemite installed here and can reproduce the 1.6 issues with Live. The good news is that there only seems to be a problem with the 32-bit version. 64-bit is working fine.

On the 32-bit version the following things happen:

  • AU version does not load at all
  • VST version has the blank window problem

This is with Live 9.1.7 32-bit, Aalto 1.6, Mac OS 10.10.2.

I'll get on this next week. Meanwhile, please try the 64-bit version of Live if you are having problems.

For me, Aalto 1.6 AU does not load at all in Live 9.1.7, neither 64 or 32 bit.
Aalto 1.6 VST is fine in 64 bit, but the white window issue in 32.

No problems at all in Logic 10.1.0. Also no problem in Reaper.

I'm running mac OS 10.10.2


@mfrasconi, or anyone with the AU not loading, can you please open a Terminal and type:

auval -v aumu Aalt MLbs

And let me know what you see there. Maybe email the result to support @ madronalabs so that it doesn't clutter up the thread.

This will perform validation on the AU and report any errors. Thanks for your help.

Not sure what changed but everything loads fine now. But still have the white window issue in Live 9.1.7 32bit. Will send the Terminal output. Thanks!

This is good info because it seems to mean the absent plugin problem can be fixed by restarting, resetting Audio Units cache, or similar.

Stuck window problem is fixed. I'm trying to complete some other fixes right now.

Just wanted to chime in here - when I use Kaivo as a VST in Ableton 32bit, I get the lingering white window problem descibed above (which the Ableton site seems to attribute to JUCE and Yosemite). When I launch Kaivo as an AU plugin, it appears to work fine, and does not leave a blank window behind. So that is an adequate workaround for now.

Do I understand that you've found a solution for the stuck window in the VST version?

[I have Ableton 9.1.7 installed and am running OS X 10.10.2]

About this window issue, Kaivo worked in previous versions of Live but the Live 9.1.7 update introduced this problem. I have a fix for it now, that is out in Aalto and will appear in Kaivo when I update Kaivo in the near future.

Hi, unfortunately this "ghost window" appears in ableton live 9.2b5 32bit and vst aalto 1.61 on mac OS X 10.10.3... :(

Hi, unfortunately this "ghost window" appears in ableton live 9.2b5 32bit and vst aalto 1.61 on mac OS X 10.10.3... :(

Can you use the 64-bit version of Live? I would recommend this if possible. Plugin hosting is much cleaner in 64-bit, this bug will be gone, and everything should be around 10% faster.

The issue does not come up for me an Aalto 1.6.1 / Live 9.1.7 / OS 10.10.2. Both AU and VST are working OK. I see there is a Live 9.1.8 version out, so I will try that and hopefully fix it if something broke again.

Can I double check with you that the AU is truly the problem and not the VST? I have had this problem with the VST in the past, but never with the AU.

I don't usually test with beta versions for compatibility because by definition they have their own bugs.

I'm having issues with Aalto 1.6.1 on OSX 10.10.4.
Live (9.2) will not load the AU, neither in 32 nor 64 bit.
And, auval -v aumu Aalt MLbs returns:

Manufacturer String: Madrona Labs
AudioUnit Name: Aalto
Component Version: 1.6.1 (0x10601)

* * PASS
FATAL ERROR: OpenAComponent: result: -50,0xFFFFFFCE

Re-ran the installer just in case, but no go.
Kaivo 1.1.0 passes all tests though..
And Gatekeeper is completely disabled.
Any pointers?

EDIT: Nevermind. Rebooting seems to have fixed the issue.

I work to make things solid but I've come to accept that AUs will always be a little fiddly, sometimes. Thanks for the update.