ForumsSoftware ← Logic 9 - audio from Aalto stops

Keeps happening - load an instance of Aalto, works for a while then suddenly the audio meters on the Aalto channel go into red and the audio completely cuts out. Sometimes all the audio from Logic, sometimes just the Aalto channel... Have to re launch Logic to fix it. Latest versions of Mac OS, Logic & Aalto. Though this also was happening in the last version of Aalto before I got the update....

Sorry to hear it. What kind of computer (CPU) do you have?

This keeps happening to me as well! The weird thing about it Is that it also seem to cut the audio from logic itself. Logic doesn't crash when this happens though, it's just silent. I will have to try to reproduce this bug to actually see under what circumstances this happens.

Logic 9.1.3/OSX 10.6.6/Macbook Pro 2.66 GHz Intel Core 2 Duo

I have the same behavior, latest versions of logic, os x (10.6.8) and aalto. I have the 17" 2.2 GHz Intel Core i7 laptop, recently got.

I can fix it by clearing the aalto plugin and then re-inserting it.

One time this happened when a one of the synth parameters was at the max and I put another patch into it and pushed it further (if this is possible?).

I'll be sure to note when it happens in the future. Since working about 2 hours today it happened about 4 or 5 times.

This patch seems to make all audio from Logic stop. Anyone else?

<Aalto pluginVersion="66049" presetName="EvilBeat" scaleName="12-equal" scaleDir="" key_voices="2" seq_host="1" seq_rate="0" seq_range="26" seq_quantize="1" seq_pw="11" seq_value0="0.133928597" seq_value1="0.00892853737" seq_value7="0.00892853737" seq_value8="0.991071463" seq_value9="0.00892853737" seq_pulse0="1" lfo_freq="0.230000004" lfo_level="1" env1_trig_select="2" env2_repeat="1.52968752" env2_attack="0.0920000002" env2_release="0.0399999991" env2_trig_select="2" env2_repeat_p="3.18000007" osc_waveshape="-0.899999976" osc_pitch_lin_p="17580" patcher_input_1="000000000000100000000000000" patcher_input_8="000000000000100100000000000" patcher_input_11="000000000000000100000000000"/>

No dropouts here for your patch. This issue is highest priority for me though.

If you try this demo component do you get the dropouts?
(Component only - I'm assuming you know how to drop this in the right place)

[EDIT] - updated component again. Should print all the numerical errors if any, and there's a button for you to copy them. click the nearly invisible button on the right to bring up the debug output.

I tried out the demo and didn't have any problems with that patch. Went back to the old component and then had issues after opening that one again. I played with the new component a while and couldn't reproduce any issues.

In other words, I'm getting somewhere? Sweet!

I played with the 1.2.4 for about half an hour yesterday as well. Didn't stumble across any dropouts or dead sound - so yes, seems like you're on the right way!

I have this problem as well. Load in an instance of Aalto 1.2.1 and very often as it loads in my monitors pop and then I get no sound at all until I quit Logic. Logic doesn't actually crash, just no sound. this is driving me crazy as there seems to be no reason for it to happen, it's very sporadic

I'm running Logic 9.1.4 on Macbook Pro OSX 10.6.8 with 4GB RAM.


The good news is I finally saw this bug occur on my own system. I did a long torture test session changing patches in Logic and was able to see some bad input from Logic that I hope is the cause of these problems.

Not sure if this will help or confuse the issue even more, but:

Since updating to 1.2 I am enjoying about a 75% success rate opening Aalto and "holding" audio. Typically I will have to clear and re-open Aalto several times before it "catches" and works continuously. The differences here being:

  1. hosting in Renoise 2.7 and audiomulch 2.1, both of which I literally experienced not a single crash or audio dropout with v1.1.

  2. the host audio is never dropped for me; only the individual instances of Aalto.

  3. with unchanged latency (and all other) settings since v1.1 in those hosts, I have been experiencing heavy audio "drag" when cpu load is anywhere around 80% or greater - in contrast to v1.1 where I was often making tracks at nearly 90% load with no glitching or dragging. At the same time overall cpu load is down 5 or 10 percent since v1.1.

  4. this seems to be worse when opening an existing project in a host where several instances of Aalto have been saved, but can happen on a fresh project too.

  5. after many many hours of use I am declaring the sequencer/clock issue from v1.2 totally disappeared.

For what it's worth/hope this helps - in case the problem is not exclusive to Logic or whatever :)

One more thought:

  1. I switched to the VST version when it became available. I realize I should fire up the AU and see what's going on...

  2. Oh yeah: macbookpro 5,3 c2d 2.8ghz, osx10.6.8

OK! There's fireworks going off outside and happy people drinking and here I am sneaking off to test that new v1.2.4 AU. :]

Works perfectly. Just tested in ReNoise - 100% success rate. No dropouts or re-starts. Was able to keep five instances of Aalto at 88% cpu load continuously with minimal drag and glitching.

New thing: I had a few instances open at ~80% total cpu load, and was switching presets with one instance with wild abandon -- no clicking or burps - very smooth.

As promised I switched back to using the Aalto 1.2.1 AU...

Wish I would have tried that a long time ago - now I can't get the audio-dropout thing to happen while putting Aalto through some torture of my own: switching presets under full cpu load, re-opening a saved project with several stored Aalto instances, tweaking parameters under full cpu load, turning audio engine on and off, complex patches, etc etc, 100 percent success so far.

This is in ReNoise. It seems to prefer the AudioUnit in general - the preset systems of ReNoise and Aalto are communicating again (reNoise is now populating the preset name in the instrument bank area for example).

Also, with the AU, Aalto does not steal keyboard focus from the host like the VST does.

Thanks for the updates. I do have one problem in Logic that I can duplicate just often enough to work on it. It's an intermittent one, which seems to match people's descriptions of the problems starting up.

The keyboard handling in different hosts is just such a huge mess for anyone who writes a plugin. Some hosts work better with the VST and some with the AU. Live won't pass keys to the AU to play notes, but the VST works OK. Other hosts only work with the AU. Fixing this crap will take a lot of time---I'm going to focus on the more severe problems and get an update out first.


Just updated to the latest version of Aalto and sadly still getting this problem with audio from Logic stopping (with a click/pop as some others have experienced). If I alt click Aalto to bypass it audio comes back, then un bypass it and it might be ok, other times not. Just to clarify - it cuts ALL the audio from Logic not just the Aalto audio.

New Mac Pro 8 core, Logic 9.1.3, 18gig RAM, 10.6.7

Sadness. The update fixed this for some people and has been tested on a few different Mac Pros, where the problems were. So I was very hopeful it was gone for good.

You can help by installing the demo version of 1.2.6 and sending me the debug output when you get a glitch. To reveal the debug pane, click the nearly-invisible button at center right in the demo version. Some debug messages will be printed every few seconds. Let a few of these go by, then click "copy text" to copy everything. Then please email to support at madronalabs!