ForumsSoftware ← Blank Aalto 1.8.5 UI on Mac OS X Mojave

After installing Aalto 1.8.5 and then running it for the first time, sometimes Aalto's UI will come up "blank"—with no cables, preset text or dial indicators. This looks bad, but fortunately the fix is easy: just relaunch the application. The next time Aalto is launched it should have all of its UI.

I've experienced this in Numerology and it didn't disappear -

Did you try other hosts? Is it still broken in Numerology?

FYI I can duplicate this in Numerology.

Yes , in Ableton it's working well , as well as Reaper - only in Numerology as far as I know

Thanks, I'm on top of this... I like Numerology :-)

Curious, any update on this? I just booted up Numerology with the intent to play with some Aalto, and ran into this :(

I updated Numerology and I can't reproduce this issue anymore. Numerology is 4.2 (build 178) here. I'm on MacOS 10.14.

Please let me know if that works for you. If not, you could also try this Aalto 1.8.3 installer:


Now I downgrade Numerology ( I had 4.2 build 182) and Aalto ( I had 1.8.5 with 1.8.3) and it's working again

Do you remember which change made it start working again?

It's also possible that it doesn't happen every time.

I updated Numerology and I can't reproduce this issue anymore. Numerology is 4.2 (build 178) here. I'm on MacOS 10.14.

I am on OSX 10.14.5 on a Macbook Air 5,2.
Aalto v 1.8.5 (AU.64)
Numerology Pro 4.2 (Build 181 + 182)

I was just testing again tonight, and Numerology is actually crashing. Maybe more of an issue with Num than with Aalto?

I noticed that certain parts of the Aalto UI will update when I change them (add patch cables, adjust dials, etc). The preset bar is always blank, but the menu will pop up when it is clicked. Loading a new preset does not update the UI -- dials and patch cords that were previously set remain.

When Aalto is closed with the preset menu open, the menu remains visible. If you click on the menu, Aalto immediately crashes. Again, this seems like it could be a Numerology UI bug, but it's always hard to tell with these things.

I'm hosting in another program right now, so I'm not banging down the doors or anything, but let me know if there's any testing I could do that would be helpful.

Thanks for the notes and offer of help. I've been in touch with Jim at Five12 and I think I know what's going on here. I'll be able to focus on this in earnest in a week or so.

I had this problem a few days ago with Logic 9.1.7 on a Mac Pro 3,1 OSX 10.9.5 using the latest builds of Aalto and Kaivo. They worked fine with all my other programs, but after launching Logic having previously updated the AUs, i got the blank UI thing. Restarting Logic did indeed fix the problem. Is it caused by some kind of caching? The audio worked fine, and i could use the plain controls option to change sounds.

Didn't see it sooner because i hardly ever use Logic. (I'm an intuitive type etc etc puns abound).

I think this issue can come up seemingly randomly, which is one reason it has been hard for me to track down. I think I've fixed it but in reality I've just moved the code around so that it happens in a different set of circumstances.

Now that Aaltoverb is shipped I'm going to take another look. Thanks for your patience.