ForumsSoftware ← Problems with the Virta demo on Windows...


I dOwnloaded and installed the Virta demo for Windows 64-bit and got some strange problems... In Reaper I get the original input sound without any effect except for one patch (and the drones of course) which do follow the input sound. In Bitwig I can't get any sound out of it except for the drones. When disabling Virta in Bitwig the original sound comes back.

In Reaper I'm confident I know what I'm doing routing-wise. In Bitwig I think I know what I'm doing.

Has the Windows demo version been confirmed working Reaper and Bitwig? Or is it me...? Any help appreciated.

Update: It's the input audio patches that don't work for me. The patches in "Virta key synth" is working fine, since the Audio module is not used in these.

Yes, it has been tested on those DAWs and should work. But setup is not straightforward. One of my beta testers kindly made a tutorial for Bitwig. As soon as I can find that I'll post it.

had the same issue here. there is a patch connection that goes out from audio/comp into formants/carrier and/or formants/program. removing it to audio/pre instead of audio/comp will make the audio signal pass through. i do have to repatch every effect presets this way in order to play them. any ideas ? otherwise, congrats randy, it's a new gem !

Hi, from what I'm hearing I'm pretty sure there is a problem with the input filter initializing properly on Windows. I'll get a fix out ASAP.

hi randy and thank you for the reply. yes it looks like the compressor doesn't respond, at least on the windows version.

I can report the same problem. Windows, Ableton Live, both 32/64 bit plugins, demo version. The meter/compressor/filters on the input don't work, only the direct "pre" output works.

Ok. So the new Windows version 1.0.1 is working better in Reaper but not as it should. After installing 1.0.1 without uninstalling version 1.0.0 I still had the same problems as before. It wasn't until I first uninstalled and then installed 1.0.1 the patches started to sound.
But... there's still the problem with the input audio leaking through to the output. I've tried several different routing setups and the input audio is not going away from the output mix.
I even tried to replace Virta with other plugins and they all did affect the sound coming out from the plugin without relaying the input audio. There is still something fishy with Virta in demo mode when running it in Reaper...
On the plus side, it works fine now in Bitwig.

OK, thanks for this feedback on Reaper. Another DAW that probably did not get a lot of beta testing. I'll have to check it out and see if I can find a solution.

Meanwhile, glad you have Bitwig to use.

Oh, ok. I don't need to say that I'm up for beta testing your next plugin if you need any help. I got a quite packed CV of plugins beta testing from all kinds of VST companies. And I'm a developer by profession. ;-)

Maybe you could build a FX version of the plugin too?

Still having problem on Windows, only "pre" lets signal through. Version 1.0.2

Still having problem on Windows, only "pre" lets signal through. Version 1.0.2

I just checked the 64 and 32 bit VSTs on Windows and could not reproduce.

Possibly it's a problem with parameters. Make sure that lo cut and hi cut are letting audio through.

what if you

  • go to preset "passthru"
  • move patch cord from "pre" to "comp"

I had same problems in Cubase 8.5 pro - no sound etc.

Found the solution few minutes ago:

In Cubase Plug-in manager -> when Virta selected -> lower part of the screen "Plug-in Information" -> Asio-Guard MUST be "inactive" (just tick it to change if it is active).

Now works like a charm (I have currently just the demo).

Thanks for posting this solution!