ForumsSoftware ← Aalto 1.6.1 installer will stay available.

I realized that I could at least give users of Mac OS 10.6 some more security by making a permanent download for Aalto 1.6.1. So if you are still on Mac OS 10.6, and would like access to it, let me know and I'll add a special license for Aalto 1.6.1 to your account. This will enable a personalized download of 1.6.1 indefinitely, and of course you can still download Aalto 1.7 or higher if and when you upgrade your computer.

I would really appreciate access to version 1.6.1 when you get chance
Awesome :)

No problem, I added it to your account.

Hello Randy, I am happily still on Snow Leopard. May I ask to get 1.6.1 to my account as well? Somehow I've missed to upgrade my Aalto from 1.5.0. Thank you.
Greetings from Stockholm.

I will happily give you a 1.6.1. Please give me until next week to take care of this. There seems to be some problem with the watermarking I need to figure out.

I am on windows but got some problem with Aalto 1.7.

Config : Bitwig 1.1.10, W7 64Bits.

When i had note on the editor, some are played, some not, and sometime it just lock on a sustained note.

Setting are the default with no sustain, and release. i tried changing the number of voice but it changed nothing.

I had no problem with previous version of Aalto before.

Is it possible to get a link for the 1.6.

I also noticed some crackle on the sound which i haven't before

Ok, after some search, i looks like to work with upper buffer : 64samples, but not with 32 samples, which is a bit anoying, as i got double latence on my system, any tought ?

Thanks for the update. I will test the MIDI response at a buffer size of 32.

There is no drawback to using a buffer size of 64, because Aalto has a minimum buffer size of 64 internally.

You might know this, but for reference, 64 samples is only about a millisecond, in which time sound travels about 1 foot (0.3m). So you get the same additional latency when moving your head 1 foot!

Hi Randy,

I've developed a similar problem after updating Aalto to 1.7. Stuck notes and a lot of hung notes, which didn't happen with the previous version (literally on the same midi clip).

My buffer size is a lot larger generally (I think I was running on 512 today) so I'm not sure it's specifically a buffer size issue.

For reference, I'm also on Bitwig (tried with both 1.1.10 and 1.2 beta [can't wait for them to implement third party MPE support!]). Windows 8.1, i7 4770k, 16gb RAM.


Hi hez, OK, I'll have to give Bitwig a look and try to reproduce this. Sorry for the trouble, this is on my bug list and I'll investigate as soon as I can.

Hello Randy,
Still haven't got the Aalto 1.6.1. download. I guess you are very busy at the moment...
I hope it's not too much hassle with my request?
Greetings from Stockholm.

Hi, sorry for the slow resolution on this. I took one stab at fixing the download problem and failed. Now I am on a retreat through this weekend working on the new plugin. I'll have to get back to the download issue next week. Thanks for your patience.

[UPDATE] another try and fail. I'm going to meet up with my web guy this week to work on it.

hey randy when all this gets worked out I would love to be added to the list as all my machine are on 10.6.8 thank you so much for thinking ahead in this way

Would love to be added to this list, too!

Of course, I’ll look back here to see who wants them and add licenses as soon as I'm able.

OK! I think we have sorted out the issues with distributing the older plugins. I added an Aalto 1.6.1 license for everyone above. Thanks for your patience.

Another Bitwigger here just wanted to confirm the problem with hung/sustained notes as well. Disabling Aalto stops the note but it usually bugs out again rather quickly.

For reference I'm using Aalto 1.7 and I have reproduced the problem in Bitwig through 1.1.10 and the 1.2 beta.

Thank You so much Randy! I got it! Best greetings from Stockholm.

Randy, I am still running 10.6.8 on my mac and would love the 1.6.1 installer for my license :)

@bktr, thanks for your purchase. You should see the 1.6.1 in "My downloads" now.

thanks for your super quick response. I am downloading now, much appreciated. :)

Hey Randy, any update on note hangs in Bitwig? I get this in both Aalto and a demoing Kaivo on multiple systems and Windows 7 and 10.

I miss being able to use your great software!

Hi, I'm working to finish the next plugin very soon, hopefully in the next few weeks. After that I will look at this issue.

Meanwhile, does Bitwig have some kind of "fixed buffer size" setting? That has been known to fix similar issues.

Thanks for the tip, I don't really know what you mean about fixed buffer size but I'll look into it. I've tried adjusting the audio buffer settings and it doesn't seem to make a difference. But Bitwig handles plugins somewhat differently than some other software so that might be part of the issue.

Even though it doesn't work properly for me at the moment I had to buy Kaivo on sale. Thanks randy, I'm excited to hear more about Virta! You create remarkably inspirational instruments.

@granum, thanks for your support!

When a DAW sends audio to a plugin for processing, it stores chunks of samples in a sample buffer. If this buffer is big, say 2048 samples, the buffering adds latency you can hear. When the buffer is very small, say 16 samples, processing overhead starts to use up lots of CPU. There is almost always a user setting to vary this buffer size.

Some DAWs do not send the same number of samples every time, but send a variable number: say 256, then 3, then 17, then 216... This is usually done to make sample-accurate automation work. However, some plugins have a problem with these different-sized chunks and this can cause bugs. So, there is sometimes a setting to disable this buffer size changing, thus: fixed buffer size.

I have tested that Aalto / Kaivo work with changing buffer sizes in the past. But maybe there is some problem that only the way Bitwig is doing it is revealing. Or maybe this is not the issue at all! But now you know what I meant.

I don't have any issues with bitwig/aalto (or kaivo) but may be because Im no a Mac.

for what its worth, I use Bitwig 1.3.5 , Aalto 1.7

Bitwigs options are simply setting a fixed buffer size (which Id recommend) or Auto which I assume 'calculates' one for you. (rather than varies it, but hey might be wrong)

some options to perhaps try are:

  • put aalto in the same process as Bitwig, rather than run it as a separate process.
  • try turning auto-suspend off

neither should be necessary, though the later may be useful with aalto, as it kind of expects to be running all the time (afaik)

Im not sure the above will do anything, as its not necessary on Mac OSX, but perhaps windows is a little more fickle