ForumsHardware ← Controlling more than just Aalto

I was wondering if anyone has any experience using custom zones combined with OSCulator to control Aalto as well as whatever else via OSC.

The most recent soundplane drive seems to refuse to connect to any port that isn't 3123, but using an 1.2 I have it sending to 3125 and OSCulator seems to be receiving the soundplane data fine. I'm then forwarding several of the messages to Aalto via port 3123 specifically:

  • /t3d/tr
  • /t3d/frm
  • /t3d/tch1
  • /t3d/tch2
  • /t3d/tch3
  • /t3d/tch4

Aalto says it is t3d connected, but doesn't seem to receive any notes.

I've tried with Aalto 1.6.0 and 1.6.1.

Using OSC data monitor to watch port 3123 I can confirm that all the same messages are getting sent to port 3123 regardless of whether I'm sending directly from the Soundplane app on 3123 or through OSCulator.

the soundplane software (1.2.4) has introduced a bug which meant it only connects on the default port - Id already reported to Randy. But Ive also now debugged it, and supplied the details of the fix to Randy.

for details see :

its a trivial bug/fix so hopefully ML will release it

note: you will need to use Aalto 1.6.1, as 1.6.0 also had a bug related to using multiple OSC addresses, and also incorrectly reported 't3d connected, when it wasn't'

I'm pretty confident the last combination I was using was client 1.2 and Aalto 1.6.1. In my frustration it is possible I was using 1.6.0 still though.

I have a performance in less than a week, so if you could link me a git patch for 1.2.4 I'll grab all the libs I need and compile me a new version of the software.

Worst case I'll see if I can figure out how to hardcode it so that it just always sends ports 3123 and 3124.

I just used version 1.1.2 in a show with several Aaltos and it was working well. here is a link:

The only issue I'm aware of that will come up with 1.1.2 is that you may have to select an Aalto OSC output on startup even if it looks like it is already selected.

I'm going to put Mark's fix in a 1.2.5 ASAP, probably today. I noticed after some playing, and I think after Mark's calling it to my attention, however, that the touch detection was somehow off in 1.2.x So I would use 1.1.2 for a show right now while I check this out.

Sorry for any headaches. I made a lot of changes recently and they are taking a little time to settle down.

Hey Randy, with sndpln 1.1.2 and Aalto 1.6.1 I'm still having the same problem as above. I'm curious what your multi-Aalto setup looks like software wise.

I have three instances of Aalto in Live. Using the gear menu in Aalto I set "OSC Enabled" for each one. Then for each one I set a different "OSC Port offset": 1, 2 and 3. On launching Live with this setup, each Aalto should broadcast itself as a Zeroconf service over UDP.

Then opening the Soundplane app (1.1.2) I see all of the Aalto instances in the OSC output menu. I can switch between them in the Soundplane app and they all play in turn.

I see, my setup would ideally be slightly different. My plan would be to have a portion of the Soundplane control space setup to control parameters on several sequencers + some Ableton parameters, and a small portion setup to control a single instance of Aalto.

Have you looked at the SoundplaneZonesOSC example in Max? This works with the ZoneExample1.json setup to send controllers as well as t3d notes. If you don't have Max then OSCulator could do the splitting— I guess this is what you are trying.

Ideally you could use just the Soundplane app to do this and have it send different controllers on different ports, but I'm a little ways off from implementing that.

I mentioned earlier that I was thinking of trying to hack that into the app, but ideally I could just get something working another way.

The only reason I have avoided max from the outset is that I was having some weird OSC binding problems, but I'll make sure I'm using some port other than 3123 and see if I have better luck than I've been having with OSCulator.

Should have just gone with max to start with! I'm just forwarding everything from max to port 3124 and getting the behaviour I'm looking for.