ForumsSoftware ← Crackle!

Thanks for your earlier answer Randy... I went ahead and purchased Aalto. So much fun to play, but the real version has even more crackle than the demo! It seems to be especially intense when it is open in my Logic 9 Studio, and much less (but still some) when the synth is closed but still playing. It also de-syncs from MIDI often.

These issues might be related to the huge CPU load Aalto requires, as one voice uses 70-90% of Logic's CPU meter on a current-generation Macbook Pro. In its current condition I can't use this synth for a show next week, although I would like to.

Hi Doug,

One voice takes about 30% of my CPU meter in Logic on my five-year-old Macbook Pro (1.83G Core Duo). So, you can do much better!

I guess the first thing I would do is try another host and see what happens. If you don't have one you can download a Numerology or Live demo.

Also, I should add: the registered version takes the same amount of CPU as the demo. So, something weird would appear to be going on.

Well , first impressions are that its a very interesting synth..
i think i lost about 3 hours just trying it out for the first time..
I have some problems with crackling as well , worse when using 2 voices, and when turning any knobs on the synth (live 8.1.4 OSX)..

i think once its been optimised a bit more and a few of the bugs have been fixed it will be very cool. The reverb sounds surprising good as does the filter.

Nice work Randy.


Something must be wrong with your Audio Interface settings. What Latency setting are you using & what Audio Interface? Crackle sounds like the latency is to low.
I installed Aalto on a MacBookPro late 2008 & and a Mac Pro.
On the MBP i can use up to 5 Voices of a complex patch per CPU with the Standart Audio Out. With my Metric Halo Interface even more.

Maybe Randy and others who are getting 30% or lower CPU could list the exact version of Logic being used and the various pertinent settings like buffer size. I rarely do real-time, so I work with 1024 frames for the buffer and pre-sequenced MIDI is fine. This is the safest setting for crackle-free audio. Folks who want interactive playback from live MIDI sources might be trying to crank down on the buffer size too much, and it might be helpful to document the limits of what works (even though it will be different for each hardware and setup).

I am making the CPU usage better every day, so I think it's pointless for me to document it in that way now.

hello randy,
having similar issues in logic with the demo. running logic 9.1.3 on osx 10.6.4 and one voice on my quad xeon 3 ghz mac pro tower is peaking one core all the way to the top with a 128 buffer causing clicks. if a core2duo can run this easily i should be able to at least get one voice going fine?
in live however, same settings/buffer, getting about 20% cpu usage per voice.
on my i7 macbook pro the demo is running fine in logic.
seems some processors are still maxing out with the 1.0 version?
looking forward to 1.1. if i can run that in logic on my tower i'm sold.
can't use a larger buffer because i use external instruments and effects.
great instrument. thanks!

Hi Hazeltine,

Thanks for this information! It seems there is some problem with Logic and Aalto and multi-CPU machines. I am trying to push the 1.1 update out the door now, which should make it better overall. I hope you stay tuned, and let me know if the 1.1 demo works better for you.

I believe that Logic and many CoreAudio hosts can only use one CPU thread for audio. GUI and other parts of the program can use all CPUs because there are no repercussions to breaking those threads apart. Logic Node is about the only way to take advantage of more than one processor. I am not 100% certain of this, but it seems to be what I have read.