ForumsNews ← Aaltoverb 2.0 released

Aaltoverb2 screen shot

Aaltoverb, our tweakable reverb for sound design and live performance, has been updated to version 2.0.

Aaltoverb now supports both Intel-compatible and Apple Silicon (M1) processors natively. In addition, it brings several new features, including:

  • MIDI Learn for all parameters.
  • LFOs for all main parameters.
  • Patch storage and new example patches.

Aaltoverb 2.0 is available now as a free update.


excited to check out the updated version but there's a problem- after i paste the licence key the plugin says that its registered but when i re-load the plugin it goes back to unregistered demo.

m1, monterey, ableton 11.

@neccss - the license should be written to ~/Music/Madrona Labs/Licenses/Aaltoverb.txt. Can you check and see if the license is there?

(EDIT) and also, please try creating a preset file when you have the plugin registered—does that work? I'm wondering if the plugin has the entitlement to write to the directory. I have not heard of this issue before.

@randy hi there! there's no license file - just a folder with presets. when I pasted the key text today I got this message: "sorry, there was an error writing the license please contact for help" even tho the plugin appears to be "registered" and i've managed to save a preset. weird.

one thing that might help - yesterday i've installed the updated aaltoverb and registered it but then i had to reset my computer and re-install everything. so technically atm i'm trying to register a second copy. not sure if it helps.

Congrats on the release, Here's those presets I made during the beta for everyone to enjoy.

@neccss sounds like a permissions problem, possibly. If the Aaltoverb plugin does not have permissions to write the license for some reason you should be able to do this to get a permanent license:

  • make the directory ~/Music/Madrona Labs/Licenses
  • save your license key to a plain text file called "Aaltoverb.txt" in the Licenses directory.

@randy it worked! thank you so much! loving the interface and can't wait to check out sumu /no rush tho

@neccss I'm glad to hear it! Enjoy.

@bobswans Glad you're having fun with Aaltoverb—thanks for sharing!

There was an error in my code creating the permissions file, if the Licenses directory was not there. This is fixed and I put up a 2.0.1 update. Good night!

Hey Randy, Just downloaded and installed 2.0.1
It show’s up as a vst3 and everything works nicely but CC, can’t get it to respond to my knobs and sliders. It doesn’t show up as an AU anymore as well.

Using LIVE 10. The altoverb.component file is in the correct plugin’s folder and I have option RESCANED all plugins. Any thoughts as to why this is happening?

Thanks, David

PS. The interface and LFO madness that can now be interjected is super-boss!

Hi David,

This is a typical issue with all AU plugins. You may need to clear the AU cache, it sounds like. Please try this:

  • Close the DAW
  • in Finder, hold down the Option key, click on the Go menu at the top of your screen and select Library
  • Delete the following files from ~/Library, if they are present:
  • Restart your computer

About the CCs, there is so much to configure, it's hard to deduce from here. If you have a different DAW to try, that could help isolate the issue.

Good Afternoon Randy,
Au is fixed!

On both of my controllers
CC works in Live 10 for D-16 Lush 101, KV331 SynthMaster.
& DP9.51 for Roli Cypher, BassStation and Aalto

Should I just reinstall Aaltoverb?

Thanks again.

@3david3 Reinstalling would not do anything about the MIDI issue you're seeing.

Does CC not work in DP for Aaltoverb?

I'll look into the issue in Live and if I can, maybe post a short video showing MIDI mapping.

Correct. CC does not work on Aaltoverb in DP.
But Aalto will receive CC in DP..
Thanks for sticking with me on this.

:) D

Hey Randy,

thanks for the update! Unfortunately my older Bitwig projects containing Aaltoverb 1 now claim that the plugin is missing, so I cannot transfer the settings to Aaltverb 2. Is there a way to install version 2 alongside version 1?

(I have to add that some or all of the projects have been made on Windows and are now being opened on an M1 mac, but still the plugin should be recognized.)

Adding to the previous question - is it possible to download the latest version of Aaltoverb 1 somewhere? So I could try if opening the projects works with that version... Many thanks

I'm just about to release an update for Aaltoverb that will address this problem. It makes version 2 into a separate plugin—like most plugin makers seem to do this. Incredibly, I've never released a major version update before Aaltoverb 2, so thanks for your understanding.

I'll add more explanation when I officially release, probably on Monday. But it should be obvious and meanwhile here are the links:


Aaltoverb 1 is still available here:

Thank you very much for the quick reply! Looking forward to the update.

And this problem made me realize how much I depend on Aaltoverb, it was popping up in so many of my projects :) Such a beautiful and versatile fx.

...I hadn't realized in my last post that you already posted the files. Installing both plugins worked perfectly, and the old projects are opening without a problem. Thanks a lot!

useful information

Hi Randy, thanks for the free update and all your efforts.

Are you planning on making the 2nd version of Aalto also free for owners of Aalto 1?

There will be a discounted upgrade price for Aalto (1) owners. Or if you bought Aalto very recently, Aalto 2 will be free.

Aalto has been out for over ten years with only free upgrades...

Thanks for the reply. Yes, I didn't mean to disregard everything you've already given to Aalto users all these years.

I should've clarified that I have only just gotten to know Aalto and have not yet acquired it because I know an update is on the horizon.

Oh I see. I'll try to figure out some reasonable parameters for the upgrade discount but I'm not sure exactly what those will be.