ForumsNews ← Virta 1.0.1 is released.

This update fixes a problem with audio input for all DAWs on Windows. It is available in the "My Downloads" area if you have a license, and the demo has also been updated. The Mac OS version is unchanged from 1.0.0.

Thanks for this update, audio now works for me. One problem however - my download runs as a demo version (even though it shows my name on the screen).

Same boat as Vulcandroid here - running as demo version with my name displayed.

Audio outputs are working fine now though! Brilliant to finally be playing with this after months of anticipation.

sorry, but I see no change in 1.0.1. It still doesn't receive audio (except for the 'pre' output).

There's also one more thing, in the dll properties/details it says under File Description: Aalto, and under Product Version: 1.7.

Thank you so much for this quick update, but I'm afraid it doesn't change a thing for Windows users. I would really recommend to build VST effect version, that would solve the problem once and for all.

Edit: hm, apparently it works for others. I deinstalled 1.0.1 and made sure there was no old version anymore, and reinstalled. Still the same.

Edit: the dll date is from March 28. It must be the old version. That's impossible.

I just updated again to fix the "demo mode" problem, so please give it a try again.

I see this "Virta / 1.7" thing in the DLL properties for the working version! some other Windows setting did not get update, apparently. This should not affect operation.

Sorry this rollout was not super smooth!

A little more info about this "Aalto / 1.7" thing: because of a leftover Visual Studio setting, Kaivo has also had the same issue for two years, and nobody noticed. So I feel confident it will not affect operation. I'll fix it in the next release.

at last, it's working at my place in Windows! Phew, that was strange. It was indeed the 'old' 1.0.0 version. Strange why it wasn't removed after deinstalling, and why the new version wasn't installed after two installations.

True, also Kaivo has Aalto name and version number. Doesn't matter, it appears these are only tags. I just tried to look everywhere why things didn't work for me, what version the dll's are, etc.

Thanks very much, now I can start to explore Virta on my main workstation.

Hotfix solves the demo thing for me Randy. Many thanks!

Phil: I also found that running the installer over the original version didn't update to 1.01 and left the original dll in place. I think I just deleted the .dll from my synths folder before installing and that did the trick. I did a 'proper' uninstall after that, but I think that was to double check the demo mode thing IIRC. Did the trick for me, but sorry to hear you're still having trouble. (edit: and indeed pleased it's solved!)

yep I manually deleted the dll's and made another install, that worked.

Yep, delete the dll's then reinstall worked perfect for me.

Anyway, thanks Randy for all your work. I've been blown away with Kaivo this last month, and Virta was a buy on sight for me, just a quick play I can tell this is going to be a lot of fun. Hopefully pick up Aalto soon, although Kaivo and Virta will probably do me for now.

Really, can't thank you enough!

I just tried to look everywhere why things didn't work for me, what version the dll's are, etc.

Yeah, of course! It was worrisome and will get fixed.

Glad it's working now. Keep me posted...

Thanks for the update Randy.

I got it working perfectly, including midi input, in FL Studio if anyone wants me to make a tutorial.

deathcomics please do :)

Here's a link to an flp file. Any instrument on effects track 2 is filtered through virta. You just need to have the "MIDI OUT" instrument on the same port as virta, which in this case is port 5.

Virta flp file

Thanks for the update breitbart