garf's Recent Posts

newsletter said 2 weeks

example: you have the 4 voices used as a 4-way freq splitter patched into the cutoff, but you only want to hear the one voice, not all 4.

would be cool, but i understand this might not be possible with the current architecture. just thinking aloud... :)

nice!

sweet! i hadn't noticed that 'step' inlet.

sounds v.handy! and a nice way of avoiding the midi map thing for each preset.

ello ello... what are those 2 extra KEY outputs (x1 & x2, it looks like)? intrigued!

nice! new bits i see:
a random button for the seq, and inlets for lfo's volume and env2's delay & attack (translucent?). also noticed that the 4-voice indicator is gone. is this because of soundplane integration? anyway looking fwd to it! cheers for the peek :)

hahah! great news. now i'll never forget (to RTFM).

hey randy, any chance of peeping those 1.3 gui tweaks you mentioned in the newsletter?

cheers fellas. porfiry, there's nothing humorous about your happy sweatshop patch. thats some creepy shit. kudos! but i'm going to turn it off now. freaking me out! techmonk, hah thats awesome - lets hear em sometime :)

go on... give us a car analogy. ferrari/skoda is a good one ;)

so you think an affordable, easily obtainable cross-platform VSTi capable of running on any modest modern computer should be... elitist?

hey all, anyone else noticed this?
i've tried using the mod wheel on my controller a few times before now with Aalto and it never worked, so i just assumed that my modwheel's CC was wrong and forgot about it til now, but i've just checked it properly and it's firing out CC1 as it should be. all my other softsynths pick up the mod data fine. this is using Live 8.2.5 on Mac 10.6.8.

also tried sending mod data via a Live clip and that doesn't work either - Aalto is just deaf to mod data here.

another very small thing i noticed: the 'Pitch' output light doesn't actually light up when receiving downwards-pitching pitchbend data (upwards lights up ok)

nooooo....

i always assumed the mod dial was an amount dial. didnt realise it was to select the cc the 'mod' receives on :/

just set to one and yep it works fine. silly me.
how come it defaults to 63?

hey randy, i know you're busy with soundplane and all, but it's been nearly 8 months now! 1.3 ETA? would really like to use mod control...

randomisation rarely makes anything useful, and mostly just sounds like random noise, something that's very easy to do with Aalto anyway. it can be cool for happy accidents, but there are more elegant ways of coming up with new sounds easily. one possible cool alternative is preset breeding, where you choose 2 presets ('mum & dad') and have a morph slider between the 2, similar to Reaktor or the vintage Greenoak Crystal vst.

not really similar, but the PolyKB has the very cool morphable oscillator modelled from the original v.rare synth:

http://www.xils-lab.com/pages/PolyKB_Development-challenge.html

like this?
http://dl.dropbox.com/u/78200/teetest.jpg

i'd buy!

would be great to have some control over the attack, decay & release curves. a slider that goes from concave to linear to convex, maybe?

  • sniffle * so proud.. right..now...

thanks randy

hi randy, i've come across what i think is a bug in 1.2.6 vst, where voice 1 becomes 'rectified' (only playing half the waveform, usually the top half). voices 2, 3 and 4 always play fine.

even though i've seen this a few times now, i can never pintpoint the cause or series of events that lead to it. next time i see it happen i'd like to grab a log snapshot to send you so you can see for yourself. where's this log stored? in previous versions of aalto there was that little square on the right hand side that opened a live log but its not there anymore...

hey randy - just happened again! lots of tweaking of the default patch into some bit noisy drone thing, then got bored with the patch and hit 'default' again - rectified 1st voice! is there any log i can grab while it's open?

yea it happens when resetting the plug to the default after much meddling, but not always, and never when you're TRYING to make it occur... but here's an audio example i grabbed when it last happened:

[url]http://dl.dropbox.com/u/78200/aalto%20first%20voice%20rectified.aif[/url]

you can hear the first voice is different from the subsequent 3. viewing the waveform, you can see it's rectified.
OSX 10.6.8 | Live 8.2.8 | Aalto 1.2.6

hey marco, you might want to try out Live's 'options.txt' workaround:

http://www.ableton.com/pages/faq/options_text

scroll down to see this...

"EnsureKeyMessagesForPlugins"

This option solves a problem with certain VST Plugins (such as NI's Reaktor), where keyboard data does not reach the plugin.

Supported since: 7.0.2b3

Note: PC ONLY!

Example: -_EnsureKeyMessagesForPlugins

agreed! that would be great.

would be nice! with phase offset dial would be nicer still...

it would also be great to choose whether the inlet controls the rate or the amount. at the moment it's rate only...

cheers bnek. your edensisland patch is great. the visual separation in the seq using the offset to actually see both riffs... wouldnt have thought to do that. very smart! :)

oh. ok thanks.

thanks randy - deleting the 2 folders and re-installing did the track.
cheers!