ForumsSoftware ← Aalto bug with Roli Rise 49 in MPE, some keys can not be played together.

Hey, I think I found a bug.

I'm using Aalto version 1.8.2, Reaper v5.70/64, a Mac, Roli's Seaboard Rise 49 as a MPE controller, and Aalto in MPE mode.

When I have multiple voices enabled in Aalto (2,3,4), it sometimes acts as if there is only one voice enabled, but only for two certain keys. So when playing a second note after holding a preceding one, the preceding one is silenced when the second plays - even though multiple voices are enabled and this is not a problem for other note combinations.

I don't have this problem if Aaltos input protocol is set to MIDI

For example, two octaves above middle C, I can't play an A note and the E note above it together.

I hope there's a fix! Thanks!

I'll have to investigate this. I'm not familiar with what you are describing.

In all the MPE and MIDI code, notes are all handled equally, so it's hard to think of why certain combinations would not be working. Can you confirm that you don't have this issue with other MPE-capable synths?

Are these failing note combinations the same if you launch the DAW and everything again?

I don't seem to have this issue with other MPE-capable synths, and it is the same when I launched everything again. I tried it on a PC and I have the same problem too.

Thanks for the additional info. I put the bug in my system and will check it out for the next release.

I might know what's going on here. I do not believe this is a bug. If I'm right, this will fix your problem:

https://support.roli.com/article/performing-adjacent-semitones-minor-2nds/

Basically, "Set the left fader (Glide) to somewhere below the maximum, and now it will be possible to play adjacent semitones." I find moving the glide setting barely below the max works great.

Thanks for the reply Stephen but that wasn't the problem for me.

I am experiencing the same issue, and a couple other MPE/polyphony-related bugs.

Bug 1 (MPE Voice Conflicts):

Same bug as OP - When using MPE, Aalto will sometimes use fewer than the total number of voices (e.g., only using 3 voices when 4 notes are being played).

Reproduction:

  1. Set Aalto input protocol to MPE
  2. Set Aalto voice control to any value greater than 1
  3. Play intervals/chords

Expected Outcome: Aalto uses all available voices.

Observed Outcome: Certain notes will steal an active voice rather than use an empty voice.

Example. Note in the monitor on the right that I am playing a minor 7th chord, but Aalto is showing that only three voices are being used.

Bug 2 (MPE Unison Pitchbend):

When using MPE and 2 or more voices in unison, Aalto does not handle pitch bends correctly. One of the voices responds to pitch bend, whereas the remaining voices stay at the original pitch that was played.

Reproduction:

  1. Set Aalto input protocol to MPE
  2. Set Aalto voice control to any value greater than 1
  3. Enable unison mode in Aalto
  4. Set Aalto bend control to match MPE controller pitch bend range
  5. Play a note and then bend it

Expected Outcome: All unison voices respond to pitch bend.

Observed Outcome: One voice responds to pitch bend, while others stay at the original pitch.

Bug 3 (Polyphony Legato):

Aalto does not seem to handle polyphony legato like I would expect.

Reproduction:

  1. Set Aalto input protocol to MIDI or MPE
  2. Set Aalto voice control to any value greater than 1
  3. Play as many notes as there are voices
  4. Play and release one more note

Expected Outcome: The note that the voice was stolen from is now on again (legato).

Observed Outcome: Both the note that the voice was stolen from and the note that stole it are now off.

Example. Note in the monitor on the right that 4 notes are being held. Then a 5th is played and released. Now there are only 3 voices active in Aalto.


As always, thank you for your hard work on improving Aalto! It's an amazing and beautiful synthesizer.

When I get a bug report this good, I weep tears of developer joy. Thanks for your help.

I'm currently working on this issue for an all-plugins update coming soon.

Update on bug #2: It looks like it may affect all modulation (velocity, aftertouch, etc.) and not just pitch bend.

I'm looking forward to the update!

Noted!