ForumsSoftware ← Kaivo stops making sound suddenly

Hello Randy,

I seem to have an issue with Kaivo AU. It just stops working all of a sudden, I can't find a pattern. It mostly happens when I change of preset, but not exclusively, because it happens also when I just let a sequencer play in an arrangement of a song.
It simply stops producing sounds. I can change the preset, or make changes in the patch; it's not frozen, it just doesn't produce sounds. It's not about the patch I can be using or anything.
I uninstalled it about two hours ago because it happened twice and tried to see if I could fix it myself, but the issue is still happening.
I'm on a Mac with Sierra using latest update of Kaivo on Ableton Live's latest version. Is there anything I can do to help you find the problem?

Thanks!

disregard, it does happen with only one voice active as well. After another restart of my system I thought it went away, but it came back again after around 30 min of tweaking a patch.

Hi Randy,
did you make any progress?

As soon as I have a fix to try I'll post a beta here!

Thank you!!

As it's a bug that makes the instrument more or less unusable, I hope you don't mind that we ask if there will be a fix, soon, once a week...

I'm working on it.

I think I have fixed this. A beta for Mac OS is available at http://madronalabs.com/media/kaivo/Kaivo1.8.4b2.pkg .

Great. When you're ready with a Windows build, I'll be happy to test it.

I will download and test this tonight

Randy, thus far I have not been able to duplicate the glitch in the new beta. My ableton did lock up and crash 2x initially, but on the third go around there were no issues and I let a patch triggered by the sequencer drone for a while. I'll update you if I notice anything else significant, but I think fix may have worked.

Good news! I'll get the full release out including a Windows version ASAP.

Will the fix be available, soon?

Yes it will. Sorry the beta is only on Mac this time because that's where I'm developing. thanks for your patience.

Yes it will. Sorry the beta is only on Mac this time because that's where I'm developing. thanks for your patience.

I've been playing a bit more and I noticed that the degradation sometimes produces extremely interesting and musical effects. Would be a very very lovely feature if one could control it : )

I only recently finally found the time to make a more in-depth use of the wonderful Kaivo, only to find that I have the same problem as described in this thread : progressive degradation/evolution of the granular module. I found a temporary reset method : click on the checkbox for "lopass" in the Gate module, twice. However this is obviously not usable, when working a long time on a composition. It seems the problem has been solved on MacOs. Will the update be available today for Windows 32-bit?

I'm working on the Windows update and will release ASAP.

I've deployed the update to the main product pages now.

Great. Looks good so far, but just some minutes in.

You may want to announce the release in the news as well. Not everyone affected will monitor this thread I guess.