ForumsSoftware ← Kaivo stops making sound suddenly

dawbakhos
Wed, Jan 04, 2017, 14:51

Hello Randy,

I seem to have an issue with Kaivo AU. It just stops working all of a sudden, I can't find a pattern. It mostly happens when I change of preset, but not exclusively, because it happens also when I just let a sequencer play in an arrangement of a song.
It simply stops producing sounds. I can change the preset, or make changes in the patch; it's not frozen, it just doesn't produce sounds. It's not about the patch I can be using or anything.
I uninstalled it about two hours ago because it happened twice and tried to see if I could fix it myself, but the issue is still happening.
I'm on a Mac with Sierra using latest update of Kaivo on Ableton Live's latest version. Is there anything I can do to help you find the problem?

Thanks!

randy
Wed, Jan 04, 2017, 18:12

I'll check into this ASAP. I can get a freeze here again and i don't know why yet. If you notice a pattern, or can make a particular preset that always causes the problem, please let me know.

randy
Thu, Jan 05, 2017, 14:23

So yesterday I was seeing these freezes. But today I can't reproduce them with the shipped 1.3.1 Kaivo. I don't have a good theory about this. I wonder if you could try downloading and installing the Kaivo 1.8.1 again, then restarting, to double check.

dawbakhos
Fri, Jan 06, 2017, 05:33

Yes, sure! Will do! Thank you!

dawbakhos
Fri, Jan 06, 2017, 06:06

Randy, sorry, one short question. I know you might be pretty busy, but you meant Kaivo 1.3.1, right? Thank you so much for your support!

randy
Fri, Jan 06, 2017, 09:33

Yes. I made a mistake—Aalto is 1.8.1.

dimmy
Thu, Feb 09, 2017, 10:00

@dawbakhos: Try switching body to 'none', then turn the plug-in off and back on (?). This isn't a fix, but it might point to the same bug I struggle with.

westernmeadowlarksong
Sun, Dec 30, 2018, 18:44

Just got Kaivo - great instrument.
I am also having problems with Kaivo stopping making sound.
Kaivo 1.8.3 (AU.64)
Live 9.7.7 64 bit
OS X 10.7.5, but I also experience this audio shutdown using my newer Mac running OSX 10.11
It usually happens when I have been running a patch for a while making lots of edits.
Like other users posting here, the audio shutdown is preceded by overdriven distorted audio.

randy
Mon, Dec 31, 2018, 10:10

Thanks for the details, and for your patience—I'll be diving into this very soon.

ms hofmann
Mon, Dec 31, 2018, 12:20

Same problem. I noticed that some patches don't do it suddenly, but rather gradually change the timbre, thin out until gone.

ms hofmann
Mon, Dec 31, 2018, 12:22

and then very slowly come back up. To me it seems that the problem lays in the granular engine – it's as if it changed grain shape.

randy
Wed, Jan 02, 2019, 09:05

This additional information is very useful, thanks!

Can you give me an example of a patch that will cause the issue consistently?

simon
Sun, Jan 06, 2019, 14:52

I didn't test if sound stops altogether, but the patches that I posted in the patch thread do have the issue with gradually degrading.

simon
Tue, Jan 08, 2019, 15:50

I checked with some of the factory patches, after Kaivo "went bad" - they have the same issue: no or barely any sound and the oscilloscope goes crazy:

celestial road trip
flange string

Switching between presets eventually resets Kaivo.

simon
Fri, Jan 11, 2019, 15:51

Did you manage to reproduce the bug, Randy?

randy
Sun, Jan 13, 2019, 09:51

No. I tried leaving celestial road trip and flange string open for hours but no kind of degradation occurred. I'll keep trying some different things but meanwhile if you have any more info about exactly how to reproduce this I'm all ears.

Thanks for the output pictures—I don't need any more of those because I get what is happening there.

simon
Mon, Jan 14, 2019, 17:13

Did you use Ableton Live? First I thought, it's maybe related to the length of the notes and grains looping and that you have to play notes. But I also ran the default patch without playing anything and it went bad as well.

Do you also use an ASIO soundcard? I doubt that's it's the driver, but you never know.

If you have any idea what may cause the issue, or what it is, let us know. Maybe I can narrow down scenarios where it does and where it doesn't occur.

Oh, I'm not sure if it was mentioned: the voices degrade independently. Some still work while others already went completely silent.

randy
Tue, Jan 15, 2019, 09:43

That's another interesting clue (the voices degrade independently). I'm just not sure at this point whether it's the granulator or resonators—there could be multiple issues confusing things as well.

I take it you are on Windows then. It's unlikely anything would be different there versus Mac OS, but possible! If you can verify that the issue happens when you are not using the resonators, only the granulator, that would be helpful. (turn resonators to "none" and hear if it ever still degrades)

simon
Tue, Jan 15, 2019, 15:25

The default patch also went bad, but I confirmed again: the issue occurs also when the Resonator and Body are off.

To analyse what's happening I tried a sine(ish) wav and recorded several stages of degrading. Looks like some FM is added step by step (not really gradually, but audibly in smaller steps).

I used this wav in the patch.

Here is a recording of the patch gradually degrading.

The recorded steps are cut together as it seems that the steps are farther apart initially, but they get faster and the change at around 1:05 was actually recorded like this.

This is the patch:
{
"demo": 0,
"licensor": "",
"key_voices": 4,
"key_mod": 1,
"key_bend": 7,
"key_unison": 0,
"key_glide": 0.010000,
"seq_local": 1,
"seq_host": 0,
"seq_loop": 1,
"seq_trig": 0,
"seq_rate": 0.250000,
"seq_ratio": 1,
"seq_rate_p": 0,
"seq_steps": 16,
"seq_steps_p": 0,
"seq_offset": 0,
"seq_offset_p": 0,
"seq_range": 12,
"seq_quantize": 0,
"seq_glide": 0,
"seq_pw": 50,
"seq_value_delay": 0,
"seq_pulse_delay": 0,
"seq_value0": 0,
"seq_value1": 0,
"seq_value2": 0,
"seq_value3": 0,
"seq_value4": 0,
"seq_value5": 0,
"seq_value6": 0,
"seq_value7": 0,
"seq_value8": 0,
"seq_value9": 0,
"seq_value10": 0,
"seq_value11": 0,
"seq_value12": 0,
"seq_value13": 0,
"seq_value14": 0,
"seq_value15": 0,
"seq_pulse0": 0,
"seq_pulse1": 0,
"seq_pulse2": 0,
"seq_pulse3": 0,
"seq_pulse4": 0,
"seq_pulse5": 0,
"seq_pulse6": 0,
"seq_pulse7": 0,
"seq_pulse8": 0,
"seq_pulse9": 0,
"seq_pulse10": 0,
"seq_pulse11": 0,
"seq_pulse12": 0,
"seq_pulse13": 0,
"seq_pulse14": 0,
"seq_pulse15": 0,
"lfo_offset": 0,
"lfo_offset_x": 0,
"lfo_offset_y": 0,
"lfo_rate": 1,
"lfo_level": 1,
"lfo_quantize": 0,
"lfo_offset_p": 0,
"lfo_rate_p": 1,
"lfo_level_p": 0,
"lfo_function": "circle",
"noise_peaks": 1,
"noise_width": 0,
"noise_falloff": 0.500000,
"noise_offset": 0,
"noise_rate": 1,
"noise_level": 0,
"noise_auto": 0,
"noise_filter": 0,
"noise_offset_p": 0,
"noise_rate_p": 0,
"noise_level_p": 0,
"env1_attack": 0.001000,
"env1_decay": 1,
"env1_sustain": 1,
"env1_release": 0.500000,
"env1_level": 1,
"env1_xvel": 1,
"env1_attack_p": 0,
"env1_decay_p": 0,
"env1_release_p": 0,
"env2_repeat": 1,
"env2_delay": 0,
"env2_attack": 0.001000,
"env2_sustain": 0,
"env2_release": 0.010000,
"env2_xvel": 0,
"env2_xenv1": 1,
"env2_delay_p": 0,
"env2_attack_p": 0,
"env2_repeat_p": 1,
"env2_release_p": 0,
"gran_position_x": 0,
"gran_position_y": 0,
"gran_rate_noise": 0,
"gran_rate": 1,
"gran_density": 1.000000,
"gran_pitch": 0,
"gran_pitch_env": 0,
"gran_pan": 0,
"gran_follow": 1,
"gran_smooth": 1,
"gran_wrap": 1,
"gran_position_x_p": 0,
"gran_position_y_p": 0,
"gran_rate_p": 1,
"gran_density_p": 1,
"gran_pitch_p": 1,
"gran_pitch_lin_p": 0,
"gran_pitch_env_p": 0,
"gran_pan_p": 0,
"gate_level": 1,
"gate_mode": 0,
"gate_decay": 1,
"gate_leak": 0,
"gate_level_p": 0.500000,
"res_position": 0.500000,
"res_brightness": 0.500000,
"res_pitch": 440,
"res_nonlin": 0,
"res_sustain": 0.500000,
"res_pan": 0,
"res_mode": "none",
"res_position_p": 0,
"res_brightness_p": 0,
"res_pitch_p": 1,
"res_pitch_lin_p": 0,
"res_nonlin_p": 0,
"res_sustain_p": 0,
"res_pan_p": 0,
"res_mix_wet": 0.500000,
"res_mix_dry": 0.500000,
"body_position_x": 0.500000,
"body_position_y": 0.500000,
"body_nonlin": 0,
"body_tone": 0.500000,
"body_pitch": 0,
"body_sustain": 0.500000,
"body_pitch_mode": 1,
"body_mode": "none",
"body_position_x_p": 0,
"body_position_y_p": 0,
"body_nonlin_p": 0,
"body_tone_p": 0,
"body_pitch_p": 1,
"body_sustain_p": 0,
"body_mix_wet": 0.500000,
"body_mix_dry": 0.500000,
"output_tilt": 0,
"output_chorus": 0,
"output_limit": 1,
"patcher_matrix": {
"type": "signal",
"width": 17,
"height": 44,
"depth": 1,
"data": [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 1, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 1, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0]
},
"key_scale": "12-equal",
"preset": "Kaivo default",
"sample_name": "Test Sine",
"maker_name": "Madrona Labs",
"app_name": "Kaivo",
"app_version": 67587
}

tubular
Tue, Jan 15, 2019, 16:22

I am having ths same issue. Mac OSX 32 Bit VST in Live 9. After tweaking a patch for a while i being to hear white noise added to the patch until it is unusable. I have tried maxing my latency settings and closing all other software to save on processor cycles. Its not just skips and pops it like white noise takes over the signal. I can change patches or sometimes have to restart Live to clear it. It makes the program almost unusable after a few minutes. Its a shame! Just bought Kaivo a few days ago.

simon
Tue, Jan 15, 2019, 16:40

I got what's happeing (but not why): step by step a one sample long oscillation is added to the signal. With each step it seems to double the amplitude. Eventually the oscillation is louder than the original signal and thus masking it. 44100 Hz is a bit too high, so you don't hear it, but the volume keeps increasing step by step.

here you can see it more clearly

My buffer size is at 512. Sampling is at 44100 Hz / 16 bit. Maybe that helps to reproduce it.

simon
Tue, Jan 15, 2019, 16:45

PS: The above audio was generated with a square wave patch. I didn't check with more complex wavetables, possibly the added FM is related to the actual wavetable and causes "noise", but it will be hard to see, if the base wave is too complex, I guess.

tubular
Wed, Jan 16, 2019, 08:18

It's happening in the AU version as well. You can see the output visualization max out and turn to a noisy square shape when it occurs.

tubular
Wed, Jan 16, 2019, 17:40

Is there a quick keypress that will kill and restart the sound engine? At least if we can't fix the bug it would be cool to have a button to press to kill the problem and start over. I know many other synths such as the virus have a quick way to kill the audio.

randy
Wed, Jan 16, 2019, 22:23

Simon, I have your "Sine Test" patch running with your source waveform, with an audio buffer size of 512. (Audio buffer size is the next thing I was going to ask, good call) I have it running for an hour now with no problems yet. Which is a bit frustrating—I'd love to fix this. I'll keep trying different things.

I listened to the recording of the patch gradually degrading that you posted. Is this cut and pasted from worse degradation that took place over time and if so, how long? If you don't play any notes but just turn the gate up to hear the oscillator does the granulator output still degrade?

Can you get the problem to occur with the Kaivo default patch and the built-in sine wave?

Also, Simon, what host version and OS version are you using? People are seeing issues on Mac OS so I've been testing there but if I still can't reproduce it I'll have to try to duplicate your setup as much as possible.

Finally, I notice you are wrapping playback around the end of the sample in the patch you sent above. If you move the horizontal position in the granulator sample to the middle does anything change? Just a longshot but if true, might help me track it down if it's wrap-related.

@tubular
There's no quick way to turn sound off and on again. If you turn the number of voices down to 1 it will turn off all voices but the first one. Maybe I should make this dial go to 0 in the future. Very sorry your new synth is acting badly but I'll fix it soon here... as soon as I can reproduce it. What Live version are you running exactly? What audio buffer size are you using? Are you able to try the 64 bit version?

randy
Wed, Jan 16, 2019, 23:15

News flash: I finally got the degradation using the 32-bit version. It took a half hour or so running the default patch. The granulator waveform did not seem to matter—I have other clues. I'm going to leave the 64-bit version running overnight and see what happens.

It makes perfect sense that I would never have run into the problem if it's 32-bit only, because I only ever run a 32 bit version long enough to do some compatibility tests.

Note that the issue we are currently discussing in this thread is probably different from what @dawbakhos posted originally! Because this granulator issue is a gradual degradation and not sudden at all.

randy
Thu, Jan 17, 2019, 00:44

And eventually the 64 bit version does it too. This might take a little while to track down because it takes so long to reproduce, but I'll figure it out.

simon
Thu, Jan 17, 2019, 03:12

That's good news. I'm on 64 bit as well. I ran several iterations today and according to my tests results seem to be quite stable if the initial setup is the same. I saved one project, recorded the audio until I got the glitch, saved and reopened. I'm at the 3rd iteration and right now each seems to have the same timing.

Let me know if you want me to upload the audio files and Ableton project.

simon
Thu, Jan 17, 2019, 03:54

This patch starts to go bad visibly after about 26 Minutes.

The Ableton file

Wave used

{
"demo": 0,
"licensor": "",
"key_voices": 1,
"key_mod": 1,
"key_bend": 7,
"key_unison": 0,
"key_glide": 0.010000,
"seq_local": 1,
"seq_host": 0,
"seq_loop": 1,
"seq_trig": 0,
"seq_rate": 0.250000,
"seq_ratio": 1,
"seq_rate_p": 0,
"seq_steps": 16,
"seq_steps_p": 0,
"seq_offset": 0,
"seq_offset_p": 0,
"seq_range": 12,
"seq_quantize": 0,
"seq_glide": 0,
"seq_pw": 50,
"seq_value_delay": 0,
"seq_pulse_delay": 0,
"seq_value0": 0,
"seq_value1": 0,
"seq_value2": 0,
"seq_value3": 0,
"seq_value4": 0,
"seq_value5": 0,
"seq_value6": 0,
"seq_value7": 0,
"seq_value8": 0,
"seq_value9": 0,
"seq_value10": 0,
"seq_value11": 0,
"seq_value12": 0,
"seq_value13": 0,
"seq_value14": 0,
"seq_value15": 0,
"seq_pulse0": 0,
"seq_pulse1": 0,
"seq_pulse2": 0,
"seq_pulse3": 0,
"seq_pulse4": 0,
"seq_pulse5": 0,
"seq_pulse6": 0,
"seq_pulse7": 0,
"seq_pulse8": 0,
"seq_pulse9": 0,
"seq_pulse10": 0,
"seq_pulse11": 0,
"seq_pulse12": 0,
"seq_pulse13": 0,
"seq_pulse14": 0,
"seq_pulse15": 0,
"lfo_offset": 0,
"lfo_offset_x": 0,
"lfo_offset_y": 0,
"lfo_rate": 1,
"lfo_level": 1,
"lfo_quantize": 0,
"lfo_offset_p": 0,
"lfo_rate_p": 1,
"lfo_level_p": 0,
"lfo_function": "circle",
"noise_peaks": 1,
"noise_width": 0,
"noise_falloff": 0.500000,
"noise_offset": 0,
"noise_rate": 1,
"noise_level": 0,
"noise_auto": 0,
"noise_filter": 0,
"noise_offset_p": 0,
"noise_rate_p": 0,
"noise_level_p": 0,
"env1_attack": 0.001000,
"env1_decay": 1,
"env1_sustain": 1,
"env1_release": 0.500000,
"env1_level": 1,
"env1_xvel": 1,
"env1_attack_p": 0,
"env1_decay_p": 0,
"env1_release_p": 0,
"env2_repeat": 1,
"env2_delay": 0,
"env2_attack": 0.001000,
"env2_sustain": 0,
"env2_release": 0.010000,
"env2_xvel": 0,
"env2_xenv1": 1,
"env2_delay_p": 0,
"env2_attack_p": 0,
"env2_repeat_p": 1,
"env2_release_p": 0,
"gran_position_x": 0.980000,
"gran_position_y": 0,
"gran_rate_noise": 0,
"gran_rate": 1,
"gran_density": 1,
"gran_pitch": -1,
"gran_pitch_env": 0,
"gran_pan": 0,
"gran_follow": 0,
"gran_smooth": 0,
"gran_wrap": 1,
"gran_position_x_p": 0,
"gran_position_y_p": 0,
"gran_rate_p": 1,
"gran_density_p": 1,
"gran_pitch_p": 1,
"gran_pitch_lin_p": 0,
"gran_pitch_env_p": 0,
"gran_pan_p": 0,
"gate_level": 0.110000,
"gate_mode": 0,
"gate_decay": 1,
"gate_leak": 0,
"gate_level_p": 0.500000,
"res_position": 0.500000,
"res_brightness": 0.500000,
"res_pitch": 440,
"res_nonlin": 0,
"res_sustain": 0.500000,
"res_pan": 0,
"res_mode": "none",
"res_position_p": 0,
"res_brightness_p": 0,
"res_pitch_p": 1,
"res_pitch_lin_p": 0,
"res_nonlin_p": 0,
"res_sustain_p": 0,
"res_pan_p": 0,
"res_mix_wet": 0.500000,
"res_mix_dry": 0.500000,
"body_position_x": 0.500000,
"body_position_y": 0.500000,
"body_nonlin": 0,
"body_tone": 0.500000,
"body_pitch": 0,
"body_sustain": 0.500000,
"body_pitch_mode": 1,
"body_mode": "none",
"body_position_x_p": 0,
"body_position_y_p": 0,
"body_nonlin_p": 0,
"body_tone_p": 0,
"body_pitch_p": 1,
"body_sustain_p": 0,
"body_mix_wet": 0.500000,
"body_mix_dry": 0.500000,
"output_tilt": 0,
"output_chorus": 0,
"output_limit": 1,
"patcher_matrix": {
"type": "signal",
"width": 17,
"height": 44,
"depth": 1,
"data": [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0]
},
"key_scale": "12-equal",
"preset": "Kaivo default",
"sample_name": "Simon/Test Square",
"maker_name": "Madrona Labs",
"app_name": "Kaivo",
"app_version": 67587
}

randy
Thu, Jan 17, 2019, 10:14

Thanks for that Simon. I'm on the trail of the issue now. More soon.

tubular
Thu, Jan 17, 2019, 17:20

Randy, thanks for working on the issue. Im making due and enjoying this great synth anyway. I am unable to try 64 bit unfortunately. Reducing the voices to 1 makes the issue disappear for me, but when I increase the voices once again it returns. I have tried a wide variety of buffer sizes and have seen the degradation at both sides of the spectrum.