ForumsSoftware ← Aalto - not remembering input protocol correctly


(Id assume this also applies to Kaivo, but not checked)

Ableton Live (9.5) now supports loading VSTs/AU from the Push (yippee!)

so now my workflow is to use the Push to create new sets and tracks without having to go back to my computer/mouse ...
this is really working nicely, as I use AUs I can save presets in ableton and all is good, I can browse them and load them
(I don't need all aalto presets, just a few of my own, so I'm not too fussed that I cannot get to the Aalso 'factory presets' as they are not stored as aupresets)

EXCEPT... when I load an au preset, it doesnt restore the input transport properly.
It correctly displays that i have it set to OSC and to offset 2, but its not actually listening.
so I have to go back to my keyboard/mouse, bring up aalto and change it back and forth.

please... can you fix this, with Push/Maschine and controller like the P8 (and quite a few others) its becoming more common place that people work away from the computer ... and don't want to return to it have to 'set things up' ... which is a real workflow killer.

also it would be handy to have the transport and port and automation targets, this would mean that I could adjust them from the push, handy if Ive put the soundplane in VpC mode, to use other instruments (e.g. u-he) and then need to switch to aalto.

BTW: I don't know if your considering NKR support but might be worth it, if this becomes a standard for preset browsing.

Im not sure how much you've been considering this trend for musicians to (physically) move away from the computer and treat it as an instruments, I find it enjoyable, allows me to focus more on music making...

I'm finding the soundplane software also needs a bit of tweaking for this... e.g. due to limitations of software synths, some might require me to use VpC, but I use T3D for ML... and also I sometimes want to switch the SP to single channel midi to control hardware synths. again these kind of things I don't want to have to come back to the computer to do...

ideally Id like to be able to do this 'switching' via midi, so I could either do via the Push, or use a midi pedal.
but perhaps thats for a different discussion ...

The correct behavior should be: changing the preset never changes the input protocol selection. So it shouldn't be restoring it. That information is stored in a song, but not in a preset. I think you are saying the following:

  • given: you have OSC input working in Aalto
  • action: you load a preset using the preset menu
  • result: OSC input stops working
  • result: the OSC protocol menu does not change
  • action: select MIDI input protocol, then select OSC
  • result: OSC input works

Is that correct? You don't have to be quite this pedantic when submitting bug reports, but from your language above I can't tell what steps to take to reproduce your problem.

You mention AU presets only. Does the VST work for you?

Thanks for the report.

sorry, I'll be more explicit

  • start live & soundplane app (in OSC mode)
  • add aalto AU to track
  • change aalto to OSC mode
  • save aalto as aupreset (save icon in live device) lets call it test.aupreset

so lets try to now reload it

  • delete previous aalto track
  • locate test.aupreset
  • double click, or load into a track

you will see the aalto AU says its in t3d mode (and also in the menus)
but the soundplane will not play it....

this is because its not really in t3d, its in midi mode... ie. the UI is not consistent to its real input protocol , you need to reselect OSC from the input menu

from what you saying above, you view this as a UI bug.

however, the issue, and hence why I tried to explain my 'use-case', is when you create a new instance of aalto its always in midi mode, I really just want to be able to create new instances of Aalto, and it to be in OSC mode (or to be able to remotely put it into OSC mode, probably more useful), and not to have to go back to my mac/mouse and go into the input menu, to change it.

this was the advantage of the way the previous version of aalto worked, which auto detected OSC, it just worked, your didnt have to go and configure it each time you dropped a new instance in a daw.

OK, I understand a little better. Originally there was no menu for selectin gprotocol—it was all automatic. Then when I added the menu (because of MIDI MPE support), is stopped being automatic.

Auto detecting t3d is not what everyone wants—imagine a system where you have t3d data flowing from your Soundplane but you want to use another Aalto or Kaivo via MIDI.

I think that Aalto should remember the last manual protocol setting and use that as the default for the next instance of the plugin created. Unfortunately there is no "plugin class preferences" that would allow this to be implemented easily. I don't see a problem with adding it and have added this to the features list.

hmm, but MPE mode should theoretically also be automatic... as MPE sends an mpe on/off from the controller.

but yeah, tricky as also if your using multiple kaivo/aalto you also need to specify offset port.

I can understand your reluctance to not save in the patch... as you may not consider it a sound parameter, but being able to alter it (and also offset) via automation would appear to be the best option given there is no real alternative.

Ive found another issue with Live/Aalto not going into T3d mode

Im not sure if its related...

due to the limitations above, as a workaround I decided to save an Aalto track (using AU) as into my default template (which is just a project) with the OSC mode already enabled.

this nearly works.... but not quite...
what happens is Aalto is correctly loaded but it does not start processing OSC/T3D messages until you make the aalto window visible

after some experimentation, i found this is because before the UI is displayed it is actually in midi mode i.e. only when the UI becomes visible does it 'switch' over to T3D mode.

*note: the same happens with saved projects when I reload them :(

EDIT: I can also confirm both issues occur on VST as well as AU

OK thanks for the report, I'll look into this.