ForumsSoftware ← Buffer issues with Aalto and Reaper

As I point out in the title there is glitching if the buffer size is set below 1024 in Reaper especially in polyphonic mode and with patches that have long release times. I have a pretty decent machine (12GB of RAM, fast processor) that easily handles multitrack projects with dozens of plugins. This happens with just one track loaded with aalto.
I saw that you 've had a similar bug fix in the past but I still have this issue.
I am on Win8.1, Reaper 4.78 and Aalto 1.6

Sorry you're having trouble, thanks for the detailed info.

Does the glitching happen if you close the Aalto window?

So I checked it with the demo version of Tracktion 6 and it still behaves the same way.The glitching doesn't have to do with aalto window being open or shut.It is behaviour similar to cpu running out of power (cause it will go away if I reduce the voices to 1 or increase the buffer size above 1024) but the cpu hit remais below 10%.Seems there is an issue with voice handling or something like that anyway.

10% CPU but glitches? That's really damn mysterious. Never heard about such an issue before.

I'm about to release an update that might possibly improve things. It's got some general stability and speed fixes. If your issue persists after the update, I can install Windows 8 and try to reproduce it.

Can you try the "fixed buffer size" option in Reaper ? Aalto should respond to varying buffer sizes properly, but it's worth a try.

Also please try a Live demo or FL if you can. I test a lot in these hosts on Windows, not so much in Reaper or Tracktion. So if it's not working in Live it's likely to be related to your OS or audio setup more generally.

Reaper is the only DAW that work with Aalto and Kaivo together in my computer (a mac mini i7). I try with max 7 and live and it glitch automaticaly. Impossible to use both with these host (but it work with just one of the two).
In my tests, Reaper seems to be the best efficient DAW for Aalto and Kaivo in term of CPU load.

If you go to "reaper / preferences / buffering", you have a lot of options to optimize the performances. But I don't really understand all, and I made my setup empirically. Maybe Randy can tell us what's the best for these softwares ?

For the CPU load, you should see both the Reaper performance meter and the computer monitor. I don't understand why, but when Reaper monitor show 10% for Aalto, the computer's monitor show something around 100%. I think that the glitches are because it mostly calculate on one core, but I'm not sure. You should try other buffering setup.

Also, it make a real big difference if you show the Aalto or Kaivo UI or not. When you have done your setup, try to close the insert windows and see if it change the CPU load.

In my mac, the VSTi of Aalto and Kaivo use a little bit less CPU than the AUi.

Another thing : if you have a soundplane and you don't put the track in record monitoring mode, you can heard the sound, but with a big latency.

So I'm going to try changing the buffering set up (try and error) and see what I can get.
Reaper does have two different cpu meters one labeled "cpu" and one labeled "cpu-realtime". The second one as I see now runs up to 40% while the first shows only 10% so that may explain the glitching in higher voice patces.
Nevertheless there seems to be some kind of erratic behaviour even if buffers and polyphony are taken into account.There are occasions where everything runs smoothly with a 40-50% cpu hit but the addition of just one compressor plugin (reaper's native reacomp-very "light" plugin) causes cpu load to skyrocket to 80% with subsequent glitching.In this case only if I unload Aalto can things get back to normal (removing the compressor plugin doesn't change anything).
Anyhow I'll post any progress I make with reaper here.I'll also try an download a demo of live to try it out together with aalto.

Reaper has (and I think FL has) a mode called "fixed buffer size" for compatibility with certain plugins that are not capable of responding to changing the process buffer size on the fly. This is desirable sometimes when a host wants to run one selected plugin in something close to realtime (for monitoring) but run other ones with a bigger buffer size for efficiency. Or also for realtime automation control, especially when rendering.

Aalto used to have problems with a changing buffer size but this was not by design, it was a bug I fixed for version 1.6 or so. I believe Kaivo has always dealt with it OK.

In general I am not a Reaper expert but it seems to continue to grow in popularity, so I'll take the time to get into further.

Definitely keep trying with the UI off, especially if you are seeing problems when you are running other plugins. Hosts all have to process audio pretty much the same way but they might deal with UI completely differently, so when I hear about problems on one host but not another I tend to think about UI issues.


In Reaper I make the DAW request the buffer from the asio driver (usually 512).I also disable the audio device from windows playback devices. I haven't been able to wrap my head around Reaper's more advanced buffering options yet.This way Aalto runs smoothly most of the time with minor glitches (cpu load around 8-20% depending on no of voices). There are instances where I'll add another vsti and things may get a little bit glitchy but this usually lasts for a couple of seconds and then everything gets back to normal.

In Live 9 things seem to run smoothly by default although with more cpu load (almost always >20%).Haven't really tried to "stress" things out with lots of plugins though

Anyhow, been making some really, really cool noises with this synth :)

So, I guess you are OK but not ideal now. Sorry it's not great for you. It's hard to diagnose what might be going on on Windows machines where there are so many different kinds of audio cards and drivers.

You can't really trust what different programs say about CPU load relative to one another. They measure different things. Look in the Performance tab in the Task Manager if you want to compare different programs in a fair way.

All, sorry to reopen an old thread but I am dealing with this myself right now. The crunching is occasionally present with two voices, persistent with three and very persistent with four. For reference, I am running Windows 10, Reaper 5.04, and whatever the latest version of Aalto is. I'm using a FocusRite Scarlett Solo soundcard, and I have a recently purchased fast PC, i7 with 16 GB. I'm convinced it's not a CPU usage problem, as Reaper shows approx. 5% CPU usage. Buffer size is currently 512, which results in an already-shitty latency of 22 ms in/out, although I ran it up to whatever the highest buffer setting is and the crunch didn't go away. I am about to spend some quality time crawling under the hood of Reaper and meddling with the buffer and latency settings, so if anyone has got Reaper running and working well with Aalto could you be so kind as to post what settings are working for you? I'll do the same when I get this resolved. Thanks!

OK, here's what is working, for now. For ref I am using the presets Muppet Dungeon and Hot Mess (oh, the names) and a few others as testers. I changed the driver from the Focusrite one to ASIO4ALL. That shaved a few m/s off of latency but didn't do much for the glitching. I went into the Reaper buffer settings and changed Thread Priority to "Time Critical" and Behavior to "15 - Very Aggressive". Much better. The final piece of the puzzle was to raise the ASIO buffer size from 512 to 1024. Now everything sounds as it should, and latency is 22 in/out, which is what it was when I started. I am pretty goddamn pleased about all of this. Really glad I can use Reaper, which looks like Garage Band, which is pretty much the level at which I interact with DAWs. I downloaded the Ableton demo and couldn't even figure out how to open a frickin' VST.

Next stop - scala files

Thanks for these good tips!