ForumsSoftware ← Aalto 1.1 knocks out all audio in Logic 9 (core audio?)

OS 10.5.8 ||
Logic 9.1.3 ||
Aalto 1.1 AU ||
MOTU 828 mk.1

I updated to Aalto 1.1 yesterday, and now the track I'm currently working on is having issues. It was working fine with the previous build of Aalto. Problems started when I opened up the Aalto 1.1 plugin window - I got a pop and all audio from Logic then stopped.

  • Disabling and then re-enabling the audio driver from Logic's preferences doesn't bring the audio back.

  • Removing Aalto 1.1 from the channel strip, saving the song, quitting and then relaunching Logic restores audio. As soon as I re-load Aalto in the channel strip, audio is once again wiped out with a pop.

Anyone else with this issue?

Ah - OK... I found the problem. The installer sent out with Aalto 1.1 does not remove the previous build of Aalto from the AU component folder (perhaps because the older AU is named differently?).

I deleted the old AU and Aalto 1.1 now works as expected.

Thanks for posting the follow up. The installer is supposed to get rid of old copies. I'm not sure what failed in your case so it's good to have this info here.

I'm on 10.6.4 -- in my "Components" folder, I'm seeing "Aalto.component" AND "Aalto1.0[My_Name].component" -- should the 1.0 have been removed? (And can or should I just delete it?)

I am deleting old Aalto components in ~/Library/... with a script. I thought the installer was deleting copies in /Library... but apparently it's not. It is safe to get rid of them yourself, then run the installer. In any case only the most recent component in /Library... should be loaded.

I'm afraid my problems are still ongoing. After removing all Aalto components, reinstalling 1.1 and running the AU scan again, the previous project seems to be working OK.

But opening a new project and then loading an instance of Aalto 1.1 knocks out all audio. Removing Aalto from the channel strip brings audio back. Any ideas?

I am actually on 10.5.8 / Logic 9 here too. So basically the only difference in my setup is the audio interface. But I can't reproduce your problem here.

I did have lots of similar glitches with Aalto 1.0, so I would love to track down what's going on.

What happens when you set the default preset, and change the number of voices? Changing the voices should restart the whole Aalto audio path.

Things I have tried:

  • Loading Aalto Default preset
  • Changing number of voices in Aalto
  • Changing audio buffer size in Logic prefs
  • Changing process buffer range in Logic prefs

This is in a simple mixdown project with a few audio tracks running. Adding an Aalto = silence. The track still plays and the meters move, but there's no sound.

Another attempt at troubleshooting:

  • Switching to Built-in audio for output brought audio back, but selecting the Aalto track and hitting a note on my keyboard sent everything silent again.

Nice bullet points.

So, am I right in understanding you have one other project in which Aalto is working?

Can you email me the project that doesn't work? Maybe then I can reproduce.

Just switched back to 1.0 for the time being to finish something off. I'm away for a few days, but I'll get back to you.

My connection is slow, so I'll have to chop out most of the audio in the non-working project in order to send it over. Hopefully it will still be sufficient for testing though.

It pains me for you to have to go back to 1.0... one thing I might try before that is copying the channel strip containing Aalto from your working project.

I'm pretty sure none of the audio matters, so you can just send the non-working project with an Aalto instance loaded and that's all. When you have time.

I'm having similar problems on my late 2008 Macbook Pro, OS 10.6.5, Logic pro 9.0.0. I'm not sure it's project dependent, it seems to happen when i first run Logic and open a project with Aalto loaded. The only way to get audio back is to quit Logic and run it again. After that it works fine for the rest of the session.

On my 2007 Mac pro OS 10.6.5, Logic Pro 8 (latest version, can't remember version number) Aalto works flawlessly though.

Hi lapsi, Can you get it to it happen often? If so, I would love to send you a debugging version so I can find out where audio is stopping.


It seems to happen randomly, I can't really repeat it deliberately, just start logic and see if it happens or not.

I could try the debugging version if that's of any use to you.

OK, let me see about making a debugging version that will help. Please stay tuned.

Apologies for not returning sooner.

I had an update blitz on my system to make sure everything had its latest versions / drivers and began a new track with Aalto 1.1.

All appeared to be fine. I wrote a part with Aalto and bounced the audio, then disabled the instance of Aalto. However yesterday I was playing around with the track some more and when I re-enabled the original instance of Aalto all my audio cut out again.

Today I can't reproduce the issue, so as Lapsi points out, the behaviour appears to be quite random!

Thanks for keeping in touch. I'm doing some overhauling related to the Windows work now-- will look at this issue soon.

Any news / progress here?

I'm afraid to say that as much as I like the synth, I've stopped using Aalto altogether to avoid this issue.

I found an oscillator out-of-range bug that may be causing your problem. Something needs to be patched into the oscillator in order for it to happen.

If you stick to the default patch, can you ever get the audio to quit?

I've tried switching to the default patch after audio has cut out, with no effect- is that what you mean?

I mean, if you just use the default patch without changing any patch cords, and let it run while you compose notes, or go to a movie or something, can you ever get the audio to cut out? The bug I found would only manifest for more complicated patches.

OK - I loaded up Aalto 1.1 in an existing project yesterday. Kept it on the default preset (silent), unused, for most of the day. No sign of the bug.

Loaded up a patch and fiddled with it. Played in some notes on the track. Switched presets around a few times and tweaked controls. No sign of the bug.

Settled on a sound I liked, saved and quit Logic. I just opened up the project again this morning, pressed play and all sound got knocked out.

– I disabled Aalto in the channel strip, re-saved the project, closed it. Sound returned on my system (iTunes etc). Re-opening the project knocked out all sound again though.

  • I loaded up the default patch in Aalto, re-saved the project, closed it and re-opened. Still no sound.

  • Quitting Logic and re-launching with the same project brings audio back, with the default preset loaded in Aalto. Re-loading the saved preset that caused the bug works again.

I can email you the preset that was originally loaded and caused the bug if you like?