ForumsSoftware ← READ ME FIRST: how to report bugs

If you are going to report a bug, please look at the topics in this forum to see if one matches your problem. If so, post in the existing thread. If not, please start a new thread with a title that describes the problem briefly. be sure to include your

  • Plugin (Aalto or Kaivo or... ) version, found at upper right
  • AU/VST host and version
  • OS Version

and then explain

  • what you did, in a way that I can repeat it
  • what you thought was supposed to happen
  • what happened instead.

I need this information to give me the best chance of doing something useful about your issue,

Hello. First off I want to say how impressed I am with Aalto. As a Windows user today is the first time I had the chance to check it out. Sounds so great and is very flexible. So I've found a few sequencer related bugs so far.

OS: windows 7 Home Premium SP1
Aalto 1.2 VST 32bit

In Live 8.2.2 the value output of the sequencer doesn't work. The gate outputs don't fire at all, you only get a pulse on the value output on the first step of the sequencer.

In Cubase Studio 5 the value output works but the gate output gets stuck. After clearing the steps the same gate pattern entered previously still plays through.

Nevermind, got it working with au.

moved post

@spunkytoofers, do you mean the arppegiator on the linnstrument?
(as you don't appear to be using the sequencer in this patch, so cant see its aalto)

if you mean there is a difference between using aalto with the linnstrument's arp on and off, Id say its most likely to be an issue with how the linnstruments arp code is working with MPE... i.e. Id talk to Geert.
(also he either has Aalto or can use the demo, so easy enough for him to test it out)

Id suspect (without looking at its code, and not having a linnstrument) its something to do with how the arp on the linnstrument is doing voice allocation, and sending the relevant pressures. (the difference in using an envelope is your using note_on gates, rather than channel pressure on the channel)

its a pity that we cannot blend the gate of the internal sequencer with Z, then you could just have your arp using the aalto sequencer.

(oh, for being able to choose the mixing mode on the inlets, and simple multiple would allow use to to this mixing, but the current add doesnt)

I don't understand what arpeggiator you mean either. In general, you have to pick either notes or aftertouch to control envelopes, not both. if the arpeggiator is sending notes and the Linnstrument is sending aftertouch, then the two things might conflict.

I made this thread to explain how to report bugs. not to report bugs in. It will help keep the site organized better if you start a new topic with your problem instead. Thanks!

@spunkytoofers thanks for tidying up, I'll reply over there.

Hi Randy,
Big Aalto fan here, love this synth!

Hey I just I found out why I lost my patch, I was working on in Ableton Live.

When you map parameters to macro knobs when grouped only the corresponding sliders when you fold open the plugin (arrow next o on offf button) keep corresponding to the actual marco values, this is not the case when you tweak knobs in th GUI so things get messy fast.. Is there a way around this or is Aalto just not suitable for macro mapping?

Thanks for the good words.

I'm sorry you lost a patch when things did not work as expected. I'll confess I have no idea what a macro knob does in Ableton, so I have not tested this. I'm also not quite clear from your description how to reproduce. Please send an email to support@madronalabs with a series of steps I can do to make the problem happen. Or, start a new thread on the forum here with your issue and the series of steps. This way I'll have the best chance of reproducing your issue and fixing it.

Is there a search function for the forum? I can't seem to find one.

There's no search built in here yet. You can use Google like this: "site:madronalabs.com thingToSearch"

I have two issues that constantly occur with Virta which I will report properly. Thanks for the nice toy.

I have an issue with Kaivo, I will report properly. Thanks again!

I installed Aalto CM. This is the soft synth that I didn't know that I have been looking for for a long time.

Randy,

Quick question. Is Aalto modeled after Snoopy? (or did BEMI steal your module configuration :)

Sorry I didn't see this post... You can start your own topics for a new question.

I have never heard of Snoopy, except the cartoon dog!