ForumsSoftware ← Aalto crashes when mapping parameters in mainstage 2.

I've been trying to assign/map my sliders ect. through mainstage. At first it appeared to be working fine. After I assigned about 8 sliders I noticed the sound had become very quiet. I tried doing it over to see what triggered it and then mainstage crashed after assigning a few sliders. I attempted several more times and each time there was some sort of problem, crashing, affecting sound, parameters would jump all over the place. I thought at first I might be overloading the cpu but tried it again and had issues after assigning only one slider.

Thanks for the report, will investigate.

Please add your Mainstage version number (2.?) and OS version.

Oh yeah sorry, os x lion & mainstage 2. Thanks. Not sure if this matters but the midi keyboard is a M-audio gravity 49.

I was messing around with the mapping again last night to try and see if I was doing somthing wrong. I wen't through the process again slowly, concerned that the issue might have been me rushing through the process. When mapping I went through each slide and slowly pushed the up and down. It's hard to say if it helped but I did manage to assign every wheel in the complex ossilator to a slider with out crashing and they all seemed to work well with the exception of the pitch wheel. the pitch wheel would jump through the first third of the wheel after bairly touching the slider and then would go extra slow through the last 2/3. Also those wave graphics seem to be a little scambled.

OK, thanks for the update. hard at work on Soundplane at the moment but I'm definitely going to look at this.

At your convience. thanks for all your hard work. Aalto is an amazing synth. :)

Hey Fraser....

You might want to check this out:

Maybe it will help?


Thanks I'll check out the link. Randy I'm sorry but the more I use my mainstage program the more I realize it's probably and issue with my mainstage than with your soft synth. All sorts of other special problems are cropping up. I'm sorry if you've spent any time looking into this. I pretty new at this computer/music thing and it's hard to tell what's causing what issue. In fact I'm getting a little frustrated with this whole thing. The amount of issues that crop up with this process are pretty overwhelming.

It's cool. I always appreciate the input---it's up to me to make any sense of it.

Don't sweat it too much Fraser - everybody gets frustrated with this stuff, especially DAW weirdness.

I have a buddy who was using Garageband when he started and he almost quit right away, it just sort of sucked for him. Then he downloaded the Audiomulch demo, and couldn't stop making music for weeks! It's just a software that he "got along" with. I never "got" Garageband either. I've never even seen MainStage.

Anyway check out Audiomulch - it works really well and you get 60 days free demo.
Also Reaper is a good one, is very cheap and has a demo to check out.
There are plenty of others to try; even if you don't find another DAW you like, you'll learn a lot of tricks by checking out how other DAWs work.

Stick with it man, you'll be loving it soon!

Thanks for the encouragement tecnomonkey, it's much needed. The current theory is I don't have enough ram (2gb). I showed the specs for Aalto to the guy I bought my Mac mini from before I bought it and he said it would run it no problem. Now he's saying I'm crazy to be trying to do what I'm doing without at least 8. Granted we never discussed the introduction of mainstage 2 but I mainly bought mainstage 2 in order to assign sliders to Aalto. I also introduced a gio pedal into the mix which is not working either. The issues I'm having don't feel like ram problems but I really don't have much to base that on. I'd have no problems forking over the cash if I new it would work but the idea of spending it and that not being the issue is kind of scary. Cash is not somthing I have a lot of right now.

Hey Fraser, hang in there, dude! The benefits you'll soon reap will outweigh the frustration. Check out the link I sent earlier; also, you might want to try RAX as an audiounits host. It's a lot less CPU hungry than MainStage. I basically use MainStage to perform with different bands; but when I'm running CPU heavy synths like AALTO, I sometimes work in RAX and then save my patches. One thing you will notice is that if you open the synth, make your changes, and close the "GUI", there is a lot less CPU typically being used. Hang tough, man!

Thanks tombitondo, I'm feeling a little better actually. Poorer but better. The chances that this issue stems for my lack of ram has increased. Once the suggestion of ram was issued I started thinking about it. I decided to try a little test. I unplugged my midi keyboard all together and didn't touch Aalto and started playing around with my gio pedal which I was also having issues with. I played around with the pedal assigned new buttons and so on not one issue. I never had any issues with Aalto before I started mapping. So perhaps because Aalto is cpu heavy introducing the mapping and perhaps even just the midi keyboard proved too much. It is still possible that there is a glitch involving my aalto that is causing my computer to do weird things but the ram. issue at this point I consider a stronger candidate. I'm still not sure what's going on but feel like I'm at least starting to narrow the possibilities. Looking forward to checking out those links. These forums have been a life saver for me. Maybe some one will read this thread down the road and benefit from my noobness and all this suffering will be for the good of man kind. ;)

You might try the Numerology demo and see if that is a host that floats your boat. The demo is very permissive, so if I recall, you can actually do some work with it before paying. It's very easy on the CPU.

Aalto really does not use that much RAM. Although, 2GB is not a lot for any DAW these days. Aalto shouldn't take more CPU when you automate parameters either.

I would try turning animations off in Aalto ('anim' button) to see if that helps.

So you think 2gb although a small amount should be able to handle Mainstage in conjunction with my Aalto, midi keyboard and gio peadal board?

I'm not crazy about switching Daw's as I'm running out of money and my gio pedal is designed to work specifically with mainstage. There's features in mainstage that allow you to assign colors's to the led's on my gio pedal board. I suspect other Daw's won't have this feature. My main objective is turning my Mac into my central effects unit for my guitar so I can create large soundscapes using looping and a variety off virtual effect pedal. My Aalto/midi keyboard is intended to support that. Other than the fact that it's not functioning properly I had assessed mainstage 2 as the perfect tool for me. I'll look further into numerology but I'd rather make my current set up work.

Turning off my 'anim' button didn't work. I was doing some more tests this morning and it's starting to look like some user knowledge issues might be at play when it comes to my pedal board issues. My issues with mapping Aalto still seem like it might be a computer issue. My pitch wheel still jumps all over the place when I map it to a slider. Even when I stop touching the slider and just play the keyboard the pitch wheel continues to jump all over the place.

If you are seeing crashes or unexpected behavior, it's not the small amount of RAM that's to blame. too little RAM would just make things slow down. So I would try to figure out the crashing / weirdness before you invest in more RAM.

I realize we got on a tangent about other DAWs but you may want to stick to Mainstage. That's fine. I'll see what I can find out.

I just posted this on the logic forum I'm using to try and sort of my gio pedal issues. It's seem's like they might be related to my Aalto issues but I'm not sure. Here's what I posted in case you find it helpful. I'm trying not to confuse things and keep separate posts about my pedal vs Aalto issues but just in case here it is.

"The current state of my issues with my bio pedal as they all seem to derive from my midi keyboard (M-audio oxygen 49). When ever I unplug my midi keyboard things seem to work as they should. When I plug it back in is messes with my gio pedal board. I was talking to tech guy this morning who's familiar with mainstage and his assessment was that the issues I'm having aren't user knowledge related and suggestion reinstalling the driver. This did not work either. I did notice when I tried reinstalling it that they didn't have a current driver update for 10.7.4. Don't know if that related but at this point I just pulling at strings. Here's the info on the driver I updated.

Operating System(s):
Mac OS 10.6.8 64-Bit, Mac OS 10.6.8 32-Bit, Mac OS 10.7.2

Supports Logic Version 9.1.3 to 9.1.6

NOTE: Please be sure to run the uninstaller for the version of DirectLink currently on your system before installing this update.

• Added support for Axiom mkII and Oxygen (blue) 3rd gen with Logic in 64-bit mode.
• Fixed an issue where the selected insert slot number was not displayed.
• Fixed inconsistent performance with DirectLink and GarageBand 5.1.
• Smoothed Encoder response with Axiom keyboards in DirectLink
• Fixed Insert parameter pages not displayed when the Pages Soft Keys were pressed
• Fixed Banking in Logic so that Banks of less than eight Tracks are created.
• Fixed the Equalizer parameters for Knobs 7 and 8 in DirectLink for GarageBand
• Fixed the direction of the Patch Buttons in DirectLink for Logic with Axiom keyboards
• Fixed a bug where Volume level would not show if two Sliders were moved simultaneously.
• Fixed a bug where the Revision was shown in all locations in the Control Surface Setup page of Logic.
• Removed unnecessary left parenthesis in the Send LCD
• Fixed: When user adjusts the master fader, then moves a track fader. The "l" of the master fader "vol" name and track level remains.
• Fixed: In Logic 9 AxiomPro LCD does not show "Pan" as MIDI feedback while on "Hold"

I talked to the guy's at Long and Mquade about my issues. They think it's because M-Audio needs to update their Driver to Os x 1.7.4 . I suspect they're right.

If you try running Mainstage on the internal audio, and then mapping some Aalto parameters to MIDI, you can tell if there is a problem without the pedal. Not that I know how to do this in Mainstage, unfortunately.

Thanks Randy,

I'm not really sure what you mean by this though. I have tried mapping aalto without my gio pedal and had issues with mapping. I've since run some other tests. I'm practically just as confused but do have some additional information. I took a loaner EDIROL roland midi keyboard from lonq and mequade for further testing. I had exactly the same issues with the loaner keyboard making my oxygen m-audio and unlikely candidate for causing all these issues. M-audio suggested downloading and os x update called (client combo). I'm not really sure what it was for but I tried it any way and had no effect.

I'd like to try uninstalling Aalto to see If I still experience mapping issues. This might tell me more of where the issue is coming from. When I searched my finder however I couldn't find an uninstall file for aalto. Does this make any sense? Any suggestions of the best way to try this test?

Aalto won't affect your setup unless you are actively running a copy of it. So I wouldn't bother trying the uninstall test. Just try mapping some parameters to another soft synth (or effect) and if that always works just fine, there is probably some problem with mapping to Aalto-- if not, then the problem is probably not Aalto's.

If you really want to try that you can just get rid of the AU component-- it's in /Library/Audio/Plug-Ins/Components. You can reinstall to replace it.

I just went back and did further testing. Insanely it seemed like everything was working as it should. This makes little sense to me as I was preforming all these tests earlier and was experiencing all my normal issues. I haven't altered my set up in anyway since the last round of testing. This might be a freak occurrence and issues could crop up again. The only other thing I can think of is that client combo update made a difference after all but for some reason didn't when I did my last round of tests. I will continue to test later on and will post my results.

There were a few things that gave me pause but weren't likely Aalto related. When I have my midi keyboard plugged in and check my midi prefs. My prefs list having 4 midi inputs. When I unplug my midi keyboard it goes down to one (my gio pedal). Shouldn't my midi keyboard also count as one? Also when I click on midi set up to further investigate nothing happens. In the tutorial when you click on set up it goes to a window with a GUI of all your midi devices. Again almost certainly non Aalto related but interesting.

Fraser, A few things to consider: (1) Get a copy of MIDI Monitor ( ) to help you diagnose what exactly is being sent out, MIDI wise. You might be choking the MIDI pipeline with some conflicting MIDI messages.
Also -- simple thing but often neglected - when running any audio programs, be sure to keep Airport turned OFF. I can't begin to tell you all of the problems that has solved for me.
I doubt AALTO is the culprit - more than likely it is (was) a conflict in the MIDI hardware. Also - be careful when running controllers and other peripherals off of the "bus". The newer mac laptops (mine is a unibody one, about 1.5 years old) seem to have less voltage coming from the USB, than my older mac laptop. I'm sure someone who is an expert can verify this.
FInally - if you want to max out the ram cheaply, consider downloading the Mactracker app. It will tell you how much RAM you can install (the Apple site frequently tells you less; for instance, Apple told me I could only do 4 gig, but I was able to actually bump it up to 6 gig!) and RAM is very cheap. You can buy it from Crucial (they have an app that downloads to your computer and tells you the cost based on your model). Then, just get someone to install it (It's a pain to do yourself because the damn screws on the laptop are smaller than jeweler screwdrivers! trust me on this.) I realize money is tight.. for me too! SO, good luck and hang in there, dude!
Here's the Mactracker website:

Thanks so much! Those are some great tips. I would have never thought of those on my own. I downloaded both Apps. That midi monitor will come in handy for sure. Amazingly those issues I was having with my mainstage crashing and mapping issues still seem to be gone. The pitch wheel still races through the first 3rd when using the slider but if that's the worst issue I have to deal with for a while I'm a happy camper! Not sure what brought about this change unfortunately. If the issue is still gone when get my own midi keyboard back I'll have to assume that Client Combo did the trick. If My computer starts acting stupid again once I get my Oxygen 49 back it will be pretty clear what is causing my issues. Some weird things are happening still but I think it's a user knowledge thing. For example when I first go into my tone wheel concert my gio pedal automatically maps to certain button functions. When I go to any other instumetnt the mapping disappears and doesn't return when even when I switch back to the same instrument. I can probably figure out why that is using my midi monitor ;). At any rate I'm pretty sure that's a user knowledge thing and certainly nothing to do with Aalto.

Also thanks for the suggestion of the ram. I was encouraged to buy legit MAC ram by the people I bought my mac from. I was looking at the crucial ram and thinking the guy at the store was probably just trying to make some extra scratch and this curial ram is probably just as good or at least good enough. I'm glad you gave it a good review. My Mac Mini will support up to 16 ram but I only wan't to buy 8. Do you think 8 ram is plenty?

Thanks for everyone's help. I know this thread deviated from an Aalto issue a while ago but the helpful suggestions keep rolling in. I will keep you posted but hopefully things remain stable for a bit so I can actually spend some time enjoying Randy's amazing synth.

Hi Fraser,
8 meg is good, of course 16 is better! One thing to consider is that if you're buying ram chips in certain configurations, then you're kinda stuck if you want to upgrade. So make sure that if you're buying blocks of 2 or 4 meg, that you can change one of them out for a bigger one in the future if you decide to go for more ram. (Crucial are very helpful on this).
Also, if the mappings are weird in the concerts in MainStage, typically there is a controller that is being triggered that you're unaware of (I personally had a problem because I was resting my hand on the drum pads, then I realized they send midi info!) SO you never know. Best thing is to go with a simple controller setup and take it real slow. Good luck and KEEP PLAYING!!! Tom.

Thanks Tom, I'll keep that in mind when I buy my ram.

I returned my loaner midi keyboard back to long and mcquade and got my Oxygen 49 back and all the issues have come back with the exception of the mapping problems I was having with Aalto. So far that seems to be stable. The fact that the edirol keyboard worked fine suggests to me that my midi keyboard it the source of all my issues. I've been communicating with M-Audio on their forum as well trying to solve this issue. Their responses are a little brief so it's hard to tell for sure but I don't get the impression that their familiar with my issue and in-fact in the last post they stated that they feel my keyboard should be working. I will continue to post any head way I make even thougt my mapping issues with Aalto seem to be stable right now. Maybe someone might find it useful later on. I really hope I can fix this issue soon. It's probably been a month now since I bought my Aalto and have barely had any time to enjoy it since all my computer time is being spent running tests and posting on forums.

hi Fraser, hope all's getting better. Let me know if you need any other insight on the mainstage/aalto issues. I'd be glad to help any way I can. Stick with it, aalto is mind blowing! You deserve to make full use of it. Good luckz, and feel free to get in touch: