ForumsSoftware ← Aalto (and probably Kaivo too) Pseudo-bug: MPE with Roli and aftertouch

mrbrowning
Mon, Dec 31, 2018, 19:06

Plugin version: 1.8.3 (AU .64)
Host: Logic Pro X v10.4.3
OS: macOS v10.14.1

What I did:

  • Set Aalto input protocol to MPE.
  • From the default patch, link the "after" output from the "KEY" section to the "level" input in the "GATE" section, with that input's scaling dial set to some value greater than 0.
  • Strike a key on a Roli Seaboard and then release the key quickly.

What I expected:
On release of the key, the "after" output in the "KEY" section would go to zero, resulting in the "GATE" section's level value going to zero in turn (note that the level of Env 1 is also an input to "GATE"'s level in this example case, but that it goes to zero in some finite time, whereas "after" seems to retains its value indefinitely after a note-off event).

What happened:
On release of the key, the "after" output in the "KEY" section maintains the last value it had before the note-off event, meaning that, when linked to "GATE"'s level, notes continue sounding even after the key has been released.

I call this a "pseudo-bug" because I'm aware that it's a peculiarity of Roli products that the aftertouch value isn't zeroed after whatever the MPE equivalent of a note-off event is. Still, for sound design purposes, it would be nice to able to control level via aftertouch while also being assured of the fact that notes would eventually stop sounding after the release of a key. I'm not sure that defaulting to zeroing aftertouch in the face of a key-off event is the right thing, but at the least making it a configurable behavior would be extremely helpful for users making use of the MPE mode with Roli controllers.

All that said, this is my first post here, and I want to take the opportunity to note that Aalto and Kaivo have made for the most fun and creatively engaging experience I've ever had with a soft synth, which is in part due to the friendliness and comprehensiveness of their documentation, so thanks Randy for your work on them!

randy
Wed, Jan 02, 2019, 09:02

Welcome, and thanks for the detailed feedback. I appreciate it. I'll take a look at this aftertouch / MPE issue and come up with a useful fix or workaround soon.

tobyb
Thu, Jan 03, 2019, 14:37

Any guidance will be much appreciated ... I am just trying to get to grips with ROLI, as a new acquisition ... when it's working it could be great, but it doesn't always seem to be doing what I want it too ... but I'm planning to try a Linn as I am a strings player, not a keyboardist ... maybe even a Soundplane B if it becomes a PC supported device, or will work with a MIDI-usb host and my MicroMonsta and NF-1m ...
I've just added Aalto and Virta to my collection meanwhile, and re-installed Reaper as Live doesn't seem to be the best DAW host ...

randy
Fri, Jan 04, 2019, 11:23

Hi Toby, the Linnstrument is known to work well with my software—and of course future Soundplanes will too. Are you running into the same issue as above with your Roli blocks?

I test all the time to ensure compatibility with Live here. It should be one of the most stable DAWs to use with my instruments. If you have a specific issue I can look at, please let me know. Reaper should be OK too.