hardware and software for electronic music 
Wed, Oct 07, 2015, 10:04

Kaivo 1.2 released.

Version 1.2 of Kaivo is now available for download for both Mac OS and Windows. This upgrade has focused on performance and usability issues. Enjoy!

  • added multiple disk selector to audio file import dialog
  • fixed granulator pitch errors
  • granulator samples now loaded as needed, speeding startup time
  • granulator optimized with SSE instructions
  • fix body model sound blowup with certain extreme settings
  • increased resolution of granulator pitch envelope
  • improve UI responsiveness under heavy load
  • MPE (Multichannel Polyphonic Expresion) support
  • improved Soundplane compatibility with all patches. (requires Soundplane 1.3 or higher)
  • new protocol switching UI (MIDI / MPE / OSC) under settings menu
  • fixed an issue where automation would not play before a note was received
  • improved voice stealing algorithm
  • optimized drawing on Mac OS



Mac OS 10.6 users please note: Kaivo now requires OS X 10.7 or higher. Unfortunately I had to make this change in order to use newer and better dev tools, specifically C++11. I am truly sorry for any inconvenience.

Wed, Oct 07, 2015, 11:38

Hi Randy
I tested 1.2 just now, unfortunately - i compared with 1.1, CPU loading increased significantly.
One of my patches which use 36-40% cpu in v1.1, load with crackles now about 100% of cpu.

After all, it should have been are optimized?

System: Win7 64bit, CPU intel, Kaivo VST 32bit; DAW Studio one 32bit

Wed, Oct 07, 2015, 11:54

With a 32-bit VST on Windows 7 64-bit in Ableton Live I see as follows:
8 voices of complex patch:
with Kaivo 1.1: 60%
with Kaivo 1.2: 50%

Your patch works OK here.
try without the plugin window—maybe it's a graphics issue?

Note that the preset format changed from 1.1 to 1.2 so when you copy from 1.2 you cannot paste into 1.1. You can copy / paste from 1.1 to 1.2.

Wed, Oct 07, 2015, 11:58

Woohoo!

Wed, Oct 07, 2015, 12:26

I saved 1.1 default patch and opened in 1.2. Before with my old school computer I was able to play 6 voices and now with 1.2 it's only 5 before crackles.

Now I have installed both of them. I will try to test and compare them.

These days when everyone is on fire with updates like OS, DAW, Plugins it's so difficult to keep up your system stable.

OSX 10.7.5
BWS 1.3 rc1 (64bit vst)

Wed, Oct 07, 2015, 12:29

Then I do not understand anything.

Basically, I really noticed for some time that some of the recent updated plug-ins (from different manufacturers) also began to cause sometimes CPU spikes or increased CPU load.

I do not exclude that the problem is really on my side. (Although usually i watch the cleanliness of the system).
But this case is just broke all tops.

Although .. maybe it's fortunately (if it really would be my problem) because this my Kaivo problem is clearly pronounced (as I have said - increasing load by more than two times), and the impact of any changes to it will be easier to monitor during the process of setting up the system.
(Maybe I'll even say thank you for that as a result :D )
But for now I'm in shock.
Well, I will try to understand what is the reason.
Maybe I'll send to email the video as proof.

"Your patch works OK here. try without the plugin window—maybe it's a graphics issue?"
Randy, the same and with closed plugin window. (for just in case - video GTX760 ,desktop).

Wed, Oct 07, 2015, 12:57

@7lakes please keep me posted, here is a good place...

@anatolyj, this is a complete mystery for me too, for the moment I have no real suggestions except maybe trying a different host in case the issue lies there. Let's see if any pattern comes to light as more people try it this week.

Wed, Oct 07, 2015, 13:07

One of my patches now playing with pitch drift or how to call it.

I load the same patch in both versions.

https://soundcloud.com/rukomuzika/kaivo-pitch-drift

Wed, Oct 07, 2015, 13:10

Randy Ok, you're right, look at the possible responses. In an extreme case, I think to completely reinstall the system.

Wed, Oct 07, 2015, 13:15

Looking really good here :)

a couple of questions:

  • is the canDo(MPE) now in place?
    (if so, its still not working in bitwig, so we can throw it back into their court)

  • "+/-" pitch, has this changed? for a patch I've recently created, it seems a bit more 'choppy' than before. could be I just need to tone it down a bit in my patches now.

Wed, Oct 07, 2015, 13:22

is the canDo(MPE) now in place?

In the VST, yes, it should be.

"+/-" pitch, has this changed?

The resolution is finer. Now 0.01, previously 0.1. Samples will also be cut off when the pitch drops so that they are playing backwards, if wrap mode is not on. If wrap is off in your patch, try enabling it.

Wed, Oct 07, 2015, 13:35

Looks like loading time of the plugin is 2.5 times faster now. :)

OSX 10.7.5 BWS 1.3 rc1 (64bit vst)

Wed, Oct 07, 2015, 16:16

Randy I sent email.

Thu, Oct 08, 2015, 04:48

No mention as to accepting MIDI Program change messages but it works !!! Yuppy!!
Might add one more line referring this.

Thanks for this and all the work ;-)

Thu, Oct 08, 2015, 08:27

Glad to hear! Other improvements that Aalto got since the 1.6.0 release should be present, too:

  • both AU and VST versions now use .mlpreset files in new JSON format
  • added preset converter to convert all old presets to new format
  • presets directory moved to ~/Music/Madrona Labs
  • improved speed of preset loading
  • fixed a problem with keyboard stealing in 64-bit VST
  • now saving window size state properly in compatible DAWs
  • added OSC enable / disable and port offset (Mac OS)
  • sequencer now quantizes to currently selected musical scale.
  • fix parameter loading when no DSP is active in application (for Max/MSP and Vienna Instruments)
  • fixed problem with sequencer retrig
  • fixed defaults for envelope trigger and x vel
  • added defaults to make MIDI patches more compatible with Soundplane / t3d
  • added clearer display of multiple channels in scope dials
  • fixed a bug affecting MIDI timing
  • added multi-channel MIDI receive for voice-per-channel operation with Soundplane, Linnstrument, etc.
  • fixed an issue affecting Save as... on some systems
  • improved graphics performance
  • fixed a problem that prevented MIDI program changes on some systems
  • fixed bug when no MIDI Programs folder was present
  • Scala keyboard mapping files (.kbm) now loaded if present in scales directory with same name as scale
  • improved UI response for dials with only a few values
  • on Save as... outside normal patch directory, warn then allow anyway.
  • fix an issue loading patches if the home directory was renamed (Mac OS)
  • fixed a bug where a program change could cause t3d to stop receiving
  • added environment menu that contains editor and OSC settings
  • added "reset editor size" option in settings
Thu, Oct 08, 2015, 13:39

Excelent !! asked for 1 got 26!!
Thanks that many more times.

Thu, Oct 08, 2015, 14:04

Hi Randy and thanks a lot for this update!

Something here that happened the first time i loaded Kaivo within Logic X.
"Kaivo default" made a sound.
Used the arrow to go to "-default" and still made a sound.
Then one more click on the arrow to go to "Metal Conch Music".
Heard an audio click/pop when clicking the arrow and then, no more sound.
Had to change Logic's buffer size to 256 (was 128 before) so Kaivo played the patches correctly.

Just to let you know.

Logic X 10.2.0
OS X 10.9.5
Processor 2 x 2.93 GHz 6-Core Intel Xeon
Memory 16 GB 1333 MHz DDR3 ECC

Regard's

Fri, Oct 09, 2015, 03:58

my own presets sound quite different now, and not in a good way. they also sound more squashed, as though the builtin limiter is working harder to flatten louder levels. has the gain staging changed at all?
randy, any chance you could re-add the last installer to my account? i tried rolling back to a previous time machine backup of the vst file but it still opens as 1.2. thanks.

Fri, Oct 09, 2015, 07:39

@garf, the only changes were to the granulator. Can you email me a patch that you feel got messed up? I can get you an old installer but I would rather fix what is bothering you. Thanks.

Fri, Oct 09, 2015, 08:52

cheers randy - done that.

Fri, Oct 09, 2015, 08:54

re: nordicauto's post about the sound when clicking... same in Live. just click anywhere in the Arrange view and Kaivo is retriggered.

Fri, Oct 09, 2015, 09:44

I have to correct myself: I changed the body to fix some possible blowups as well, which unavoidably altered some sounds. The changes should be pretty subtle. I don't understand what's going on with Garf's path yet but will check into it. I'll wait for the dust to settle then get an update out.

re: the clicking / triggering: I can't reproduce this. Garf can you send me an email with as many details as possible, including Live version, 64/32, VST/AU, OS as well as the patch and a short audio clip? Actually, this is a case where video woul dbe even better if that's possible. I don't doubt that something is going on, but I can't imagine any way that clicking could trigger a sound.

[EDIT]

The granulator is responsible for the difference here—Garf's patch is using the a sine wave in the granulator with wrap off, and the way this is clipping creates more noise in the 1.2 version of the granulator. I'll see what I can do to make this more like it was in 1.1.

Fri, Oct 09, 2015, 10:01

randy, use the preset that i emailed to you and try this in Live:
in Arrange view, arm the Kaivo track and press any note on a controller, then click around the Arranger grid... bow! bow! bow!

sent you a vid

Wed, Oct 14, 2015, 05:37

hi randy, did you receive the vid i emailed to you? it might have been too large but it seemed to send ok, with no 'undelivered' message.

Wed, Oct 14, 2015, 08:22

Yes I did, thanks. In your patch the envelope is being triggered by the sequencer. I imagine that Live is resetting its clock whenever the armed track is clicked on, which will retrigger the envelope.